Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.410 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.410/0.410/0.410/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c30/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Jul 03 16:29:56.304215 osdx systemd-journald[1553]: Runtime Journal (/run/log/journal/831aeca402c6428e9ad074105f874d77) is 2.4M, max 9.7M, 7.3M free.
Jul 03 16:29:56.309718 osdx systemd-journald[1553]: Received client request to rotate journal, rotating.
Jul 03 16:29:56.309778 osdx systemd-journald[1553]: Vacuuming done, freed 0B of archived journals from /run/log/journal/831aeca402c6428e9ad074105f874d77.
Jul 03 16:29:56.318614 osdx OSDxCLI[51782]: User 'admin' executed a new command: 'system journal clear'.
Jul 03 16:29:56.781934 osdx osdx-coredump[141421]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Jul 03 16:29:56.792413 osdx OSDxCLI[51782]: User 'admin' executed a new command: 'system coredump delete all'.
Jul 03 16:29:58.126095 osdx OSDxCLI[51782]: User 'admin' entered the configuration menu.
Jul 03 16:29:58.201460 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Jul 03 16:29:58.295366 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Jul 03 16:29:58.363966 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Jul 03 16:29:58.479037 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Jul 03 16:29:58.543968 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Jul 03 16:29:58.640640 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Jul 03 16:29:58.702509 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Jul 03 16:29:58.803040 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Jul 03 16:29:58.872557 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Jul 03 16:29:59.001919 osdx OSDxCLI[51782]: User 'admin' added a new cfg line: 'show working'.
Jul 03 16:29:59.186565 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Jul 03 16:29:59.203908 osdx (udev-worker)[141486]: Network interface NamePolicy= disabled on kernel command line.
Jul 03 16:29:59.398895 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Jul 03 16:29:59.401127 osdx cfgd[1223]: [51782]Completed change to active configuration
Jul 03 16:29:59.405228 osdx dhcpd[141525]: Wrote 0 leases to leases file.
Jul 03 16:29:59.437925 osdx OSDxCLI[51782]: User 'admin' committed the configuration.
Jul 03 16:29:59.438895 osdx dhcpd[141525]:
Jul 03 16:29:59.438899 osdx dhcpd[141525]: No subnet declaration for eth0 (no IPv4 addresses).
Jul 03 16:29:59.438902 osdx dhcpd[141525]: ** Ignoring requests on eth0.  If this is not what
Jul 03 16:29:59.438904 osdx dhcpd[141525]:    you want, please write a subnet declaration
Jul 03 16:29:59.438907 osdx dhcpd[141525]:    in your dhcpd.conf file for the network segment
Jul 03 16:29:59.438909 osdx dhcpd[141525]:    to which interface eth0 is attached. **
Jul 03 16:29:59.438911 osdx dhcpd[141525]:
Jul 03 16:29:59.442668 osdx dhcpd[141525]: Server starting service.
Jul 03 16:29:59.459113 osdx OSDxCLI[51782]: User 'admin' left the configuration menu.
Jul 03 16:29:59.966060 osdx dhcpd[141525]: DHCPDISCOVER from de:ad:be:ef:6c:30 via 20.0.0.2
Jul 03 16:29:59.966552 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:20:de:ad:be:ef:6c:10:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=58956 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Jul 03 16:30:00.967062 osdx dhcpd[141525]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 03 16:30:00.967878 osdx dhcpd[141525]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 03 16:30:00.970571 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:20:de:ad:be:ef:6c:10:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=59052 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Jul 03 16:30:01.009234 osdx dhcpd[141525]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.2