Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.310 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.310/0.310/0.310/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c30/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Jul 17 17:15:50.297387 osdx systemd-journald[1360]: Runtime Journal (/run/log/journal/1136bfd51c6042e9ac02f83740870c06) is 2.4M, max 9.7M, 7.3M free.
Jul 17 17:15:50.300493 osdx systemd-journald[1360]: Received client request to rotate journal, rotating.
Jul 17 17:15:50.300557 osdx systemd-journald[1360]: Vacuuming done, freed 0B of archived journals from /run/log/journal/1136bfd51c6042e9ac02f83740870c06.
Jul 17 17:15:50.312316 osdx OSDxCLI[75437]: User 'admin' executed a new command: 'system journal clear'.
Jul 17 17:15:50.763111 osdx osdx-coredump[163388]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Jul 17 17:15:50.774123 osdx OSDxCLI[75437]: User 'admin' executed a new command: 'system coredump delete all'.
Jul 17 17:15:52.120269 osdx OSDxCLI[75437]: User 'admin' entered the configuration menu.
Jul 17 17:15:52.198262 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Jul 17 17:15:52.279275 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Jul 17 17:15:52.346013 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Jul 17 17:15:52.434340 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Jul 17 17:15:52.503736 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Jul 17 17:15:52.588058 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Jul 17 17:15:52.655996 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Jul 17 17:15:52.738479 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Jul 17 17:15:52.806065 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Jul 17 17:15:52.915525 osdx OSDxCLI[75437]: User 'admin' added a new cfg line: 'show working'.
Jul 17 17:15:53.068553 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Jul 17 17:15:53.096538 osdx (udev-worker)[163475]: Network interface NamePolicy= disabled on kernel command line.
Jul 17 17:15:53.276740 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Jul 17 17:15:53.279127 osdx cfgd[1028]: [75437]Completed change to active configuration
Jul 17 17:15:53.283398 osdx dhcpd[163514]: Wrote 0 leases to leases file.
Jul 17 17:15:53.307649 osdx dhcpd[163514]:
Jul 17 17:15:53.307654 osdx dhcpd[163514]: No subnet declaration for eth0 (no IPv4 addresses).
Jul 17 17:15:53.307656 osdx dhcpd[163514]: ** Ignoring requests on eth0.  If this is not what
Jul 17 17:15:53.307659 osdx dhcpd[163514]:    you want, please write a subnet declaration
Jul 17 17:15:53.307661 osdx dhcpd[163514]:    in your dhcpd.conf file for the network segment
Jul 17 17:15:53.307664 osdx dhcpd[163514]:    to which interface eth0 is attached. **
Jul 17 17:15:53.307666 osdx dhcpd[163514]:
Jul 17 17:15:53.309480 osdx OSDxCLI[75437]: User 'admin' committed the configuration.
Jul 17 17:15:53.312615 osdx dhcpd[163514]: Server starting service.
Jul 17 17:15:53.325869 osdx OSDxCLI[75437]: User 'admin' left the configuration menu.
Jul 17 17:15:53.953462 osdx dhcpd[163514]: DHCPDISCOVER from de:ad:be:ef:6c:30 via 20.0.0.2
Jul 17 17:15:53.956516 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:20:de:ad:be:ef:6c:10:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=24664 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Jul 17 17:15:54.954404 osdx dhcpd[163514]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 17 17:15:54.955104 osdx dhcpd[163514]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 17 17:15:54.956488 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:20:de:ad:be:ef:6c:10:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=24867 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Jul 17 17:15:54.962567 osdx dhcpd[163514]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.2