Relay

This scenario shows how to configure service dhcp-relay. The relay agent must be used when the DHCP server and the DHCP clients are not connected to the same layer 2 domain.

../../../_images/toplogy.svg

Test DHCP Relay

Description

This example demonstrates how to configure a DHCP relay instance in DUT0 to forward DHCP requests from DUT2 to DUT1.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.540 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.540/0.540/0.540/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c30/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
    eth1                                down   down

Test DHCP Relay With Giaddr

Description

This example demonstrates how to set the gateway IP address (giaddr) in the IP address. This value must be set in an IP address that the DHCP server can reach.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.3/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1 giaddr 20.0.0.3
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.167 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.167/0.167/0.167/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c30/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.3
Show output
Jul 30 12:01:24.248484 osdx systemd-journald[1361]: Runtime Journal (/run/log/journal/022a18c941d64f479a590b363c3a1b1d) is 2.4M, max 9.7M, 7.3M free.
Jul 30 12:01:24.251853 osdx systemd-journald[1361]: Received client request to rotate journal, rotating.
Jul 30 12:01:24.251897 osdx systemd-journald[1361]: Vacuuming done, freed 0B of archived journals from /run/log/journal/022a18c941d64f479a590b363c3a1b1d.
Jul 30 12:01:24.257691 osdx OSDxCLI[96653]: User 'admin' executed a new command: 'system journal clear'.
Jul 30 12:01:24.669420 osdx osdx-coredump[130295]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Jul 30 12:01:24.678630 osdx OSDxCLI[96653]: User 'admin' executed a new command: 'system coredump delete all'.
Jul 30 12:01:25.925179 osdx OSDxCLI[96653]: User 'admin' entered the configuration menu.
Jul 30 12:01:25.998003 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Jul 30 12:01:26.084933 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Jul 30 12:01:26.138511 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Jul 30 12:01:26.228503 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Jul 30 12:01:26.292692 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'show working'.
Jul 30 12:01:26.405763 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Jul 30 12:01:26.433153 osdx (udev-worker)[130362]: Network interface NamePolicy= disabled on kernel command line.
Jul 30 12:01:26.505916 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Jul 30 12:01:26.507925 osdx cfgd[1029]: [96653]Completed change to active configuration
Jul 30 12:01:26.511484 osdx dhcpd[130383]: Wrote 0 leases to leases file.
Jul 30 12:01:26.531530 osdx dhcpd[130383]:
Jul 30 12:01:26.531535 osdx dhcpd[130383]: No subnet declaration for eth0 (no IPv4 addresses).
Jul 30 12:01:26.531538 osdx dhcpd[130383]: ** Ignoring requests on eth0.  If this is not what
Jul 30 12:01:26.531540 osdx dhcpd[130383]:    you want, please write a subnet declaration
Jul 30 12:01:26.531542 osdx dhcpd[130383]:    in your dhcpd.conf file for the network segment
Jul 30 12:01:26.531545 osdx dhcpd[130383]:    to which interface eth0 is attached. **
Jul 30 12:01:26.531547 osdx dhcpd[130383]:
Jul 30 12:01:26.537731 osdx dhcpd[130383]: Server starting service.
Jul 30 12:01:26.539038 osdx OSDxCLI[96653]: User 'admin' committed the configuration.
Jul 30 12:01:26.553866 osdx OSDxCLI[96653]: User 'admin' left the configuration menu.
Jul 30 12:01:27.096626 osdx dhcpd[130383]: DHCPDISCOVER from de:ad:be:ef:6c:30 via 20.0.0.3
Jul 30 12:01:28.097577 osdx dhcpd[130383]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.3
Jul 30 12:01:28.098390 osdx dhcpd[130383]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:30 (osdx) via 20.0.0.3
Jul 30 12:01:28.113050 osdx dhcpd[130383]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.3

Test DHCP Relay With GRE Tunnel

Description

This example demonstrates how to configure a DHCP relay that forwards DHCP requests to the DHCP server through a GRE tunnel (upstream).

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces tunnel tun1 address 1.0.0.2/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.2
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp holdtime 5
set interfaces tunnel tun1 nhrp nhs 1.0.0.1 nbma 10.0.0.1
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 1.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS upstream-interface tun1
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces tunnel tun1 address 1.0.0.1/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.1
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set protocols static route 20.0.0.0/24 next-hop 1.0.0.2
set service dhcp-server shared-network dummy subnet 1.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.339 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.339/0.339/0.339/0.000 ms

Step 5: Ping IP address 1.0.0.1 from DUT0:

admin@DUT0$ ping 1.0.0.1 count 1 size 56 timeout 1
Show output
PING 1.0.0.1 (1.0.0.1) 56(84) bytes of data.
64 bytes from 1.0.0.1: icmp_seq=1 ttl=64 time=0.387 ms

--- 1.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.387/0.387/0.387/0.000 ms

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c30/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
    eth1                                down   down

Test DHCP Relay With Multiple Instances

Description

This example demonstrates how to configure multiple DHCP relay instances.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 300 address 30.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS2 downstream-interface eth1.300
set service dhcp-relay INS2 server 10.0.0.1
set service dhcp-relay INS2 upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set interfaces ethernet eth0 vif 300 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.300 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.300/0.300/0.300/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c30/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
    eth1                                down   down

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

30.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c30/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
    eth1                                down   down

Step 7: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.2
DHCPACK on 30.0.0.50 to [^\)]+\) via 30.0.0.2
Show output
Jul 30 12:01:44.249471 osdx systemd-journald[1361]: Runtime Journal (/run/log/journal/022a18c941d64f479a590b363c3a1b1d) is 2.4M, max 9.7M, 7.3M free.
Jul 30 12:01:44.249858 osdx systemd-journald[1361]: Received client request to rotate journal, rotating.
Jul 30 12:01:44.249885 osdx systemd-journald[1361]: Vacuuming done, freed 0B of archived journals from /run/log/journal/022a18c941d64f479a590b363c3a1b1d.
Jul 30 12:01:44.259684 osdx OSDxCLI[96653]: User 'admin' executed a new command: 'system journal clear'.
Jul 30 12:01:44.625765 osdx osdx-coredump[130931]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Jul 30 12:01:44.633062 osdx OSDxCLI[96653]: User 'admin' executed a new command: 'system coredump delete all'.
Jul 30 12:01:46.061941 osdx OSDxCLI[96653]: User 'admin' entered the configuration menu.
Jul 30 12:01:46.121064 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Jul 30 12:01:46.209064 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Jul 30 12:01:46.256814 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Jul 30 12:01:46.349935 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Jul 30 12:01:46.405281 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50'.
Jul 30 12:01:46.545267 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'show working'.
Jul 30 12:01:46.641699 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Jul 30 12:01:46.672807 osdx (udev-worker)[131001]: Network interface NamePolicy= disabled on kernel command line.
Jul 30 12:01:46.786101 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Jul 30 12:01:46.788115 osdx cfgd[1029]: [96653]Completed change to active configuration
Jul 30 12:01:46.792701 osdx dhcpd[131022]: Wrote 0 leases to leases file.
Jul 30 12:01:46.816811 osdx dhcpd[131022]:
Jul 30 12:01:46.816815 osdx dhcpd[131022]: No subnet declaration for eth0 (no IPv4 addresses).
Jul 30 12:01:46.816818 osdx dhcpd[131022]: ** Ignoring requests on eth0.  If this is not what
Jul 30 12:01:46.816820 osdx dhcpd[131022]:    you want, please write a subnet declaration
Jul 30 12:01:46.816823 osdx dhcpd[131022]:    in your dhcpd.conf file for the network segment
Jul 30 12:01:46.816825 osdx dhcpd[131022]:    to which interface eth0 is attached. **
Jul 30 12:01:46.816827 osdx dhcpd[131022]:
Jul 30 12:01:46.820000 osdx OSDxCLI[96653]: User 'admin' committed the configuration.
Jul 30 12:01:46.825877 osdx dhcpd[131022]: Server starting service.
Jul 30 12:01:46.834496 osdx OSDxCLI[96653]: User 'admin' left the configuration menu.
Jul 30 12:01:47.420665 osdx dhcpd[131022]: DHCPDISCOVER from de:ad:be:ef:6c:30 via 20.0.0.2
Jul 30 12:01:47.520308 osdx dhcpd[131022]: DHCPDISCOVER from de:ad:be:ef:6c:30 via 30.0.0.2
Jul 30 12:01:48.421550 osdx dhcpd[131022]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 30 12:01:48.422637 osdx dhcpd[131022]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 30 12:01:48.447107 osdx dhcpd[131022]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 30 12:01:48.520562 osdx dhcpd[131022]: DHCPOFFER on 30.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 30.0.0.2
Jul 30 12:01:48.521451 osdx dhcpd[131022]: DHCPREQUEST for 30.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:30 (osdx) via 30.0.0.2
Jul 30 12:01:48.538453 osdx dhcpd[131022]: DHCPACK on 30.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 30.0.0.2