Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.251 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.251/0.251/0.251/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Dec 04 15:57:18.267038 osdx systemd-journald[1388]: Runtime Journal (/run/log/journal/e00a4863307c4ec795c6f3eeb7a5801b) is 1.3M, max 9.7M, 8.4M free.
Dec 04 15:57:18.270035 osdx systemd-journald[1388]: Received client request to rotate journal, rotating.
Dec 04 15:57:18.270100 osdx systemd-journald[1388]: Vacuuming done, freed 0B of archived journals from /run/log/journal/e00a4863307c4ec795c6f3eeb7a5801b.
Dec 04 15:57:18.280004 osdx OSDxCLI[1605]: User 'admin' executed a new command: 'system journal clear'.
Dec 04 15:57:18.690422 osdx osdx-coredump[101166]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Dec 04 15:57:18.697502 osdx OSDxCLI[1605]: User 'admin' executed a new command: 'system coredump delete all'.
Dec 04 15:57:20.228836 osdx OSDxCLI[1605]: User 'admin' entered the configuration menu.
Dec 04 15:57:20.304282 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Dec 04 15:57:20.387296 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Dec 04 15:57:20.442465 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Dec 04 15:57:20.568319 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Dec 04 15:57:20.625981 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Dec 04 15:57:20.713626 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Dec 04 15:57:20.771502 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Dec 04 15:57:20.860119 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Dec 04 15:57:20.913970 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Dec 04 15:57:21.030603 osdx OSDxCLI[1605]: User 'admin' added a new cfg line: 'show working'.
Dec 04 15:57:21.190012 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Dec 04 15:57:21.221516 osdx (udev-worker)[101258]: Network interface NamePolicy= disabled on kernel command line.
Dec 04 15:57:21.682519 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Dec 04 15:57:21.684244 osdx cfgd[1056]: [1605]Completed change to active configuration
Dec 04 15:57:21.686797 osdx dhcpd[101303]: Wrote 0 leases to leases file.
Dec 04 15:57:21.713138 osdx dhcpd[101303]:
Dec 04 15:57:21.713321 osdx dhcpd[101303]: No subnet declaration for eth0 (no IPv4 addresses).
Dec 04 15:57:21.713371 osdx dhcpd[101303]: ** Ignoring requests on eth0.  If this is not what
Dec 04 15:57:21.713412 osdx dhcpd[101303]:    you want, please write a subnet declaration
Dec 04 15:57:21.713452 osdx dhcpd[101303]:    in your dhcpd.conf file for the network segment
Dec 04 15:57:21.713494 osdx dhcpd[101303]:    to which interface eth0 is attached. **
Dec 04 15:57:21.713534 osdx dhcpd[101303]:
Dec 04 15:57:21.725482 osdx OSDxCLI[1605]: User 'admin' committed the configuration.
Dec 04 15:57:21.734229 osdx dhcpd[101303]: Server starting service.
Dec 04 15:57:21.775344 osdx OSDxCLI[1605]: User 'admin' left the configuration menu.
Dec 04 15:57:22.330400 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=28111 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Dec 04 15:57:22.330445 osdx dhcpd[101303]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Dec 04 15:57:23.331324 osdx dhcpd[101303]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Dec 04 15:57:23.331954 osdx dhcpd[101303]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Dec 04 15:57:23.334002 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=28350 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Dec 04 15:57:23.346866 osdx dhcpd[101303]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2