Relay

This scenario shows how to configure service dhcp-relay. The relay agent must be used when the DHCP server and the DHCP clients are not connected to the same layer 2 domain.

../../../_images/toplogy.svg

Test DHCP Relay

Description

This example demonstrates how to configure a DHCP relay instance in DUT0 to forward DHCP requests from DUT2 to DUT1.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.214 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.214/0.214/0.214/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Giaddr

Description

This example demonstrates how to set the gateway IP address (giaddr) in the IP address. This value must be set in an IP address that the DHCP server can reach.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.3/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1 giaddr 20.0.0.3
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.178 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.178/0.178/0.178/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.3
Show output
Oct 30 12:25:42.298527 osdx systemd-journald[1716]: Runtime Journal (/run/log/journal/ec1e6df9c86a4e70bec24fbb88487109) is 1.3M, max 9.7M, 8.4M free.
Oct 30 12:25:42.300461 osdx systemd-journald[1716]: Received client request to rotate journal, rotating.
Oct 30 12:25:42.300507 osdx systemd-journald[1716]: Vacuuming done, freed 0B of archived journals from /run/log/journal/ec1e6df9c86a4e70bec24fbb88487109.
Oct 30 12:25:42.307733 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:25:42.755287 osdx osdx-coredump[103956]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:25:42.763337 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:25:44.251258 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:25:44.371852 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Oct 30 12:25:44.451371 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Oct 30 12:25:44.552850 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Oct 30 12:25:44.609588 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Oct 30 12:25:44.722638 osdx ERROR[103966]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:25:44.724861 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:25:44.812481 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:25:44.834985 osdx (udev-worker)[104026]: Network interface NamePolicy= disabled on kernel command line.
Oct 30 12:25:44.956761 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Oct 30 12:25:44.959423 osdx dhcpd[104049]: Wrote 0 leases to leases file.
Oct 30 12:25:44.960833 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:25:44.992577 osdx dhcpd[104049]:
Oct 30 12:25:44.992590 osdx dhcpd[104049]: No subnet declaration for eth0 (no IPv4 addresses).
Oct 30 12:25:44.992597 osdx dhcpd[104049]: ** Ignoring requests on eth0.  If this is not what
Oct 30 12:25:44.992602 osdx dhcpd[104049]:    you want, please write a subnet declaration
Oct 30 12:25:44.992608 osdx dhcpd[104049]:    in your dhcpd.conf file for the network segment
Oct 30 12:25:44.992614 osdx dhcpd[104049]:    to which interface eth0 is attached. **
Oct 30 12:25:44.992618 osdx dhcpd[104049]:
Oct 30 12:25:45.003426 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:25:45.008579 osdx dhcpd[104049]: Server starting service.
Oct 30 12:25:45.020120 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:25:45.543364 osdx dhcpd[104049]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.3
Oct 30 12:25:46.544265 osdx dhcpd[104049]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
Oct 30 12:25:46.545472 osdx dhcpd[104049]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
Oct 30 12:25:46.568006 osdx dhcpd[104049]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3

Test DHCP Relay With GRE Tunnel

Description

This example demonstrates how to configure a DHCP relay that forwards DHCP requests to the DHCP server through a GRE tunnel (upstream).

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces tunnel tun1 address 1.0.0.2/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.2
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp holdtime 5
set interfaces tunnel tun1 nhrp nhs 1.0.0.1 nbma 10.0.0.1
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 1.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS upstream-interface tun1
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces tunnel tun1 address 1.0.0.1/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.1
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set protocols static route 20.0.0.0/24 next-hop 1.0.0.2
set service dhcp-server shared-network dummy subnet 1.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.215 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.215/0.215/0.215/0.000 ms

Step 5: Ping IP address 1.0.0.1 from DUT0:

admin@DUT0$ ping 1.0.0.1 count 1 size 56 timeout 1
Show output
PING 1.0.0.1 (1.0.0.1) 56(84) bytes of data.
64 bytes from 1.0.0.1: icmp_seq=1 ttl=64 time=0.289 ms

--- 1.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.289/0.289/0.289/0.000 ms

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Multiple Instances

Description

This example demonstrates how to configure multiple DHCP relay instances.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 300 address 30.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS2 downstream-interface eth1.300
set service dhcp-relay INS2 server 10.0.0.1
set service dhcp-relay INS2 upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set interfaces ethernet eth0 vif 300 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.252 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.252/0.252/0.252/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

30.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 7: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.2
DHCPACK on 30.0.0.50 to [^\)]+\) via 30.0.0.2
Show output
Oct 30 12:26:05.287546 osdx systemd-journald[1716]: Runtime Journal (/run/log/journal/ec1e6df9c86a4e70bec24fbb88487109) is 1.3M, max 9.7M, 8.4M free.
Oct 30 12:26:05.290307 osdx systemd-journald[1716]: Received client request to rotate journal, rotating.
Oct 30 12:26:05.290370 osdx systemd-journald[1716]: Vacuuming done, freed 0B of archived journals from /run/log/journal/ec1e6df9c86a4e70bec24fbb88487109.
Oct 30 12:26:05.298188 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:26:05.736104 osdx osdx-coredump[104632]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:26:05.743503 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:26:07.524780 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:26:07.627597 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Oct 30 12:26:07.684966 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Oct 30 12:26:07.811312 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Oct 30 12:26:07.885269 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Oct 30 12:26:08.004229 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50'.
Oct 30 12:26:08.084027 osdx ERROR[104644]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:26:08.089515 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:26:08.206313 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:26:08.228846 osdx (udev-worker)[104706]: Network interface NamePolicy= disabled on kernel command line.
Oct 30 12:26:08.390664 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Oct 30 12:26:08.394013 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:26:08.397371 osdx dhcpd[104729]: Wrote 0 leases to leases file.
Oct 30 12:26:08.421044 osdx dhcpd[104729]:
Oct 30 12:26:08.421052 osdx dhcpd[104729]: No subnet declaration for eth0 (no IPv4 addresses).
Oct 30 12:26:08.421054 osdx dhcpd[104729]: ** Ignoring requests on eth0.  If this is not what
Oct 30 12:26:08.421057 osdx dhcpd[104729]:    you want, please write a subnet declaration
Oct 30 12:26:08.421059 osdx dhcpd[104729]:    in your dhcpd.conf file for the network segment
Oct 30 12:26:08.421061 osdx dhcpd[104729]:    to which interface eth0 is attached. **
Oct 30 12:26:08.421063 osdx dhcpd[104729]:
Oct 30 12:26:08.427481 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:26:08.438380 osdx dhcpd[104729]: Server starting service.
Oct 30 12:26:08.442922 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:26:09.101233 osdx dhcpd[104729]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Oct 30 12:26:09.252997 osdx dhcpd[104729]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 30.0.0.2
Oct 30 12:26:10.101951 osdx dhcpd[104729]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Oct 30 12:26:10.102551 osdx dhcpd[104729]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Oct 30 12:26:10.123421 osdx dhcpd[104729]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Oct 30 12:26:10.253245 osdx dhcpd[104729]: DHCPOFFER on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
Oct 30 12:26:10.253720 osdx dhcpd[104729]: DHCPREQUEST for 30.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
Oct 30 12:26:10.272050 osdx dhcpd[104729]: DHCPACK on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2