Static Server

Test suite that connects DUT1 over DUT0 using DoH. Meanwhile, DUT0 establishes a connection with the upstream server and forwards DNS queries to it.

Server With Upstream DoH

Description

Configures DUT0 to connect, using DNS-over-HTTPS (DoH) over an upstream server.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 address 10.215.168.64/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server cert file 'running://dns.dut0.crt'
set service dns proxy server cert key 'running://dns.dut0.key'
set service dns proxy server-name RD
set service dns proxy static RD protocol dns-over-https hash 68c25678167aeb1c6d3c5a2eee24cda4b0e03dd3e6b1ed1872dbed544374329e
set service dns proxy static RD protocol dns-over-https host name remote.dns
set service dns proxy static RD protocol dns-over-https ip 10.215.168.1
set service dns resolver local
set service dns static host-name teldat.com inet 10.11.12.13
set system certificate trust 'running://remote.dns-server.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Run command system journal show | cat at DUT0 and check if output matches the following regular expressions:

^(?m)^.*\[RD\] OK \(DoH\) - rtt: \d+ms$
Show output
Oct 30 12:21:01.308174 osdx systemd-journald[1923]: Runtime Journal (/run/log/journal/877522c656344df9b9ad28416f5f036f) is 2.0M, max 15.3M, 13.2M free.
Oct 30 12:21:01.309613 osdx systemd-journald[1923]: Received client request to rotate journal, rotating.
Oct 30 12:21:01.309676 osdx systemd-journald[1923]: Vacuuming done, freed 0B of archived journals from /run/log/journal/877522c656344df9b9ad28416f5f036f.
Oct 30 12:21:01.320492 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:21:01.693011 osdx osdx-coredump[218123]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:21:01.701414 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:21:02.244774 osdx OSDxCLI[101074]: User 'admin' entered the configuration menu.
Oct 30 12:21:02.356191 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.64/24'.
Oct 30 12:21:02.409864 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Oct 30 12:21:02.518710 osdx ERROR[218136]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:02.520056 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:02.609620 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:21:02.714216 osdx cfgd[1636]: [101074]Completed change to active configuration
Oct 30 12:21:02.747933 osdx OSDxCLI[101074]: User 'admin' committed the configuration.
Oct 30 12:21:02.769677 osdx OSDxCLI[101074]: User 'admin' left the configuration menu.
Oct 30 12:21:02.931061 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'ping 10.215.168.1      count 1 size 56 timeout 1'.
Oct 30 12:21:04.037815 osdx OSDxCLI[101074]: User 'admin' entered the configuration menu.
Oct 30 12:21:04.097902 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set system certificate trust running://remote.dns-server.crt'.
Oct 30 12:21:04.199384 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server-name RD'.
Oct 30 12:21:04.266036 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD protocol dns-over-https host name remote.dns'.
Oct 30 12:21:04.355829 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD protocol dns-over-https ip 10.215.168.1'.
Oct 30 12:21:04.415323 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD protocol dns-over-https hash 68c25678167aeb1c6d3c5a2eee24cda4b0e03dd3e6b1ed1872dbed544374329e'.
Oct 30 12:21:04.508219 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server cert file 'running://dns.dut0.crt''.
Oct 30 12:21:04.563029 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server cert key 'running://dns.dut0.key''.
Oct 30 12:21:04.659049 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns resolver local'.
Oct 30 12:21:04.719101 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns static host-name teldat.com inet 10.11.12.13'.
Oct 30 12:21:04.838662 osdx ERROR[218249]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:04.839658 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:04.931292 osdx ca-certificates[218276]: Updating certificates in /etc/ssl/certs...
Oct 30 12:21:05.427437 osdx ca-certificates[219280]: 1 added, 0 removed; done.
Oct 30 12:21:05.430202 osdx ca-certificates[219286]: Running hooks in /etc/ca-certificates/update.d...
Oct 30 12:21:05.433836 osdx ca-certificates[219288]: done.
Oct 30 12:21:05.577965 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Oct 30 12:21:05.579192 osdx cfgd[1636]: [101074]Completed change to active configuration
Oct 30 12:21:05.581319 osdx OSDxCLI[101074]: User 'admin' committed the configuration.
Oct 30 12:21:05.601052 osdx OSDxCLI[101074]: User 'admin' left the configuration menu.
Oct 30 12:21:05.608235 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] dnscrypt-proxy 2.0.45
Oct 30 12:21:05.608375 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Network connectivity detected
Oct 30 12:21:05.608574 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Dropping privileges
Oct 30 12:21:05.611124 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Network connectivity detected
Oct 30 12:21:05.611124 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Now listening to 127.0.0.1:53 [UDP]
Oct 30 12:21:05.611124 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Now listening to 127.0.0.1:53 [TCP]
Oct 30 12:21:05.611124 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Now listening to https://[::]:3000/dns-query [DoH]
Oct 30 12:21:05.611124 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Firefox workaround initialized
Oct 30 12:21:05.611124 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Loading the set of cloaking rules from [/tmp/tmpwm0iw3re]
Oct 30 12:21:05.760063 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system journal show | cat'.
Oct 30 12:21:05.833050 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] [RD] OK (DoH) - rtt: 139ms
Oct 30 12:21:05.833050 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] Server with the lowest initial latency: RD (rtt: 139ms)
Oct 30 12:21:05.833050 osdx dnscrypt-proxy[219348]: [2024-10-30 12:21:05] [NOTICE] dnscrypt-proxy is ready - live servers: 1

Step 3: Set the following configuration in DUT1:

set interfaces ethernet eth0 address 10.215.168.65/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server-name DUT0
set service dns proxy static DUT0 protocol dns-over-https hash 03295b816ca312fa63159644c87d7f1f3e816ef296bb36dc7b22f9a40d9a64e1
set service dns proxy static DUT0 protocol dns-over-https host name dns.dut0
set service dns proxy static DUT0 protocol dns-over-https host port 3000
set service dns proxy static DUT0 protocol dns-over-https ip 10.215.168.64
set service dns static host-name dns.dut0 inet 10.215.168.64
set service ssh
set system certificate trust 'running://CA.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

^(?m)^.*\[DUT0\] OK \(DoH\) - rtt: \d+ms$
Show output
Oct 30 12:21:01.310093 osdx systemd-journald[1716]: Runtime Journal (/run/log/journal/ec1e6df9c86a4e70bec24fbb88487109) is 1.2M, max 9.7M, 8.4M free.
Oct 30 12:21:01.311026 osdx systemd-journald[1716]: Received client request to rotate journal, rotating.
Oct 30 12:21:01.311071 osdx systemd-journald[1716]: Vacuuming done, freed 0B of archived journals from /run/log/journal/ec1e6df9c86a4e70bec24fbb88487109.
Oct 30 12:21:01.320244 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:21:01.786260 osdx osdx-coredump[88641]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:21:01.793995 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:21:03.009306 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:21:03.084568 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.65/24'.
Oct 30 12:21:03.170744 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Oct 30 12:21:03.222191 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service ssh'.
Oct 30 12:21:03.331788 osdx ERROR[88650]: unexpected
                                          Traceback (most recent call last):
                                            File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                          FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:03.334921 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:03.423048 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:21:03.599342 osdx systemd[1]: Starting ssh.service - OpenBSD Secure Shell server...
Oct 30 12:21:03.610548 osdx sshd[88734]: Server listening on 0.0.0.0 port 22.
Oct 30 12:21:03.610766 osdx sshd[88734]: Server listening on :: port 22.
Oct 30 12:21:03.610903 osdx systemd[1]: Started ssh.service - OpenBSD Secure Shell server.
Oct 30 12:21:03.641672 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:21:03.667561 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:21:03.682632 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:21:03.832016 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'ping 10.215.168.64      count 1 size 56 timeout 1'.
Oct 30 12:21:06.022413 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:21:06.126953 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns static host-name dns.dut0 inet 10.215.168.64'.
Oct 30 12:21:06.180907 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set system certificate trust running://CA.crt'.
Oct 30 12:21:06.297448 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy server-name DUT0'.
Oct 30 12:21:06.383951 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https host name dns.dut0'.
Oct 30 12:21:06.473913 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https host port 3000'.
Oct 30 12:21:06.533356 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https ip 10.215.168.64'.
Oct 30 12:21:06.643342 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https hash 03295b816ca312fa63159644c87d7f1f3e816ef296bb36dc7b22f9a40d9a64e1'.
Oct 30 12:21:06.712201 osdx ERROR[88783]: unexpected
                                          Traceback (most recent call last):
                                            File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                          FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:06.717501 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:06.816210 osdx ca-certificates[88810]: Updating certificates in /etc/ssl/certs...
Oct 30 12:21:07.302398 osdx ca-certificates[89815]: 1 added, 0 removed; done.
Oct 30 12:21:07.306563 osdx ca-certificates[89820]: Running hooks in /etc/ca-certificates/update.d...
Oct 30 12:21:07.310492 osdx ca-certificates[89822]: done.
Oct 30 12:21:07.395388 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Oct 30 12:21:07.397349 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:21:07.404803 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:21:07.417642 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] dnscrypt-proxy 2.0.45
Oct 30 12:21:07.417809 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] Network connectivity detected
Oct 30 12:21:07.417880 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] Dropping privileges
Oct 30 12:21:07.420516 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] Network connectivity detected
Oct 30 12:21:07.420516 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] Now listening to 127.0.0.1:53 [UDP]
Oct 30 12:21:07.420516 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] Now listening to 127.0.0.1:53 [TCP]
Oct 30 12:21:07.420516 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] Firefox workaround initialized
Oct 30 12:21:07.420516 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] Loading the set of cloaking rules from [/tmp/tmpb6fn_1l8]
Oct 30 12:21:07.420946 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:21:07.597365 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal show | cat'.
Oct 30 12:21:07.709405 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] [DUT0] OK (DoH) - rtt: 132ms
Oct 30 12:21:07.709405 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] Server with the lowest initial latency: DUT0 (rtt: 132ms)
Oct 30 12:21:07.709405 osdx dnscrypt-proxy[89829]: [2024-10-30 12:21:07] [NOTICE] dnscrypt-proxy is ready - live servers: 1

Step 5: Run command show host lookup teldat.com type A at DUT1 and check if output contains the following tokens:

teldat.com has address 10.11.12.13
Show output
;; communications error to ::1#53: connection refused
;; communications error to ::1#53: connection refused
teldat.com has address 10.11.12.13

Server With Upstream DoH With Stamp

Description

Configures DUT0 to connect, using DNS-over-HTTPS (DoH) over an upstream server (generating a DNS stamp and using it to configure the connection).

Scenario

Step 1: Run command service dns proxy stamp calculate dns-over-https host-name remote.dns host-path /dns-query host-port 443 ip 10.215.168.1 hash 68c25678167aeb1c6d3c5a2eee24cda4b0e03dd3e6b1ed1872dbed544374329e at DUT0 and expect this output:

Show output
sdns://AgAAAAAAAAAADDEwLjIxNS4xNjguMSBowlZ4FnrrHG08Wi7uJM2ksOA90-ax7Rhy2-1UQ3QyngpyZW1vdGUuZG5zCi9kbnMtcXVlcnk

Step 2: Set the following configuration in DUT0:

set interfaces ethernet eth0 address 10.215.168.64/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server cert file 'running://dns.dut0.crt'
set service dns proxy server cert key 'running://dns.dut0.key'
set service dns proxy server-name RD
set service dns proxy static RD stamp 'sdns://AgAAAAAAAAAADDEwLjIxNS4xNjguMSBowlZ4FnrrHG08Wi7uJM2ksOA90-ax7Rhy2-1UQ3QyngpyZW1vdGUuZG5zCi9kbnMtcXVlcnk'
set service dns resolver local
set service dns static host-name teldat.com inet 10.11.12.13
set system certificate trust 'running://remote.dns-server.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Run command system journal show | cat at DUT0 and check if output matches the following regular expressions:

^(?m)^.*\[RD\] OK \(DoH\) - rtt: \d+ms$
Show output
Oct 30 12:21:13.289393 osdx systemd-journald[1923]: Runtime Journal (/run/log/journal/877522c656344df9b9ad28416f5f036f) is 2.0M, max 15.3M, 13.3M free.
Oct 30 12:21:13.290808 osdx systemd-journald[1923]: Received client request to rotate journal, rotating.
Oct 30 12:21:13.290862 osdx systemd-journald[1923]: Vacuuming done, freed 0B of archived journals from /run/log/journal/877522c656344df9b9ad28416f5f036f.
Oct 30 12:21:13.300358 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:21:13.617107 osdx osdx-coredump[220994]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:21:13.624561 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:21:14.087288 osdx OSDxCLI[101074]: User 'admin' entered the configuration menu.
Oct 30 12:21:14.168802 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.64/24'.
Oct 30 12:21:14.269982 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Oct 30 12:21:14.359230 osdx ERROR[221002]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:14.359926 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:14.470802 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:21:14.566433 osdx cfgd[1636]: [101074]Completed change to active configuration
Oct 30 12:21:14.599148 osdx OSDxCLI[101074]: User 'admin' committed the configuration.
Oct 30 12:21:14.614519 osdx OSDxCLI[101074]: User 'admin' left the configuration menu.
Oct 30 12:21:14.765289 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'ping 10.215.168.1      count 1 size 56 timeout 1'.
Oct 30 12:21:15.832435 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'service dns proxy stamp calculate dns-over-https host-name remote.dns host-path /dns-query host-port 443 ip 10.215.168.1 hash 68c25678167aeb1c6d3c5a2eee24cda4b0e03dd3e6b1ed1872dbed544374329e'.
Oct 30 12:21:15.976592 osdx OSDxCLI[101074]: User 'admin' entered the configuration menu.
Oct 30 12:21:16.035177 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set system certificate trust running://remote.dns-server.crt'.
Oct 30 12:21:16.150290 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server-name RD'.
Oct 30 12:21:16.210633 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD stamp 'sdns://AgAAAAAAAAAADDEwLjIxNS4xNjguMSBowlZ4FnrrHG08Wi7uJM2ksOA90-ax7Rhy2-1UQ3QyngpyZW1vdGUuZG5zCi9kbnMtcXVlcnk''.
Oct 30 12:21:16.308364 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server cert file 'running://dns.dut0.crt''.
Oct 30 12:21:16.382235 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server cert key 'running://dns.dut0.key''.
Oct 30 12:21:16.479302 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns static host-name teldat.com inet 10.11.12.13'.
Oct 30 12:21:16.533142 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns resolver local'.
Oct 30 12:21:16.632917 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns static host-name teldat.com inet 10.11.12.13'.
Oct 30 12:21:16.708410 osdx ERROR[221117]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:16.709353 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:16.820202 osdx ca-certificates[221144]: Updating certificates in /etc/ssl/certs...
Oct 30 12:21:17.298551 osdx ca-certificates[222147]: 1 added, 0 removed; done.
Oct 30 12:21:17.301473 osdx ca-certificates[222154]: Running hooks in /etc/ca-certificates/update.d...
Oct 30 12:21:17.305016 osdx ca-certificates[222156]: done.
Oct 30 12:21:17.447179 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Oct 30 12:21:17.448561 osdx cfgd[1636]: [101074]Completed change to active configuration
Oct 30 12:21:17.450728 osdx OSDxCLI[101074]: User 'admin' committed the configuration.
Oct 30 12:21:17.467668 osdx OSDxCLI[101074]: User 'admin' left the configuration menu.
Oct 30 12:21:17.470165 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] dnscrypt-proxy 2.0.45
Oct 30 12:21:17.470310 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Network connectivity detected
Oct 30 12:21:17.470439 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Dropping privileges
Oct 30 12:21:17.472279 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Network connectivity detected
Oct 30 12:21:17.472313 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Now listening to 127.0.0.1:53 [UDP]
Oct 30 12:21:17.472313 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Now listening to 127.0.0.1:53 [TCP]
Oct 30 12:21:17.472341 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Now listening to https://[::]:3000/dns-query [DoH]
Oct 30 12:21:17.472341 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Firefox workaround initialized
Oct 30 12:21:17.472341 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Loading the set of cloaking rules from [/tmp/tmpfaxxt_7j]
Oct 30 12:21:17.614560 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system journal show | cat'.
Oct 30 12:21:17.627919 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] [RD] OK (DoH) - rtt: 127ms
Oct 30 12:21:17.627919 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] Server with the lowest initial latency: RD (rtt: 127ms)
Oct 30 12:21:17.627919 osdx dnscrypt-proxy[222216]: [2024-10-30 12:21:17] [NOTICE] dnscrypt-proxy is ready - live servers: 1

Step 4: Run command service dns proxy stamp calculate dns-over-https host-name dns.dut0 host-path /dns-query host-port 3000 ip 10.215.168.64 hash 03295b816ca312fa63159644c87d7f1f3e816ef296bb36dc7b22f9a40d9a64e1 at DUT1 and expect this output:

Show output
sdns://AgAAAAAAAAAADTEwLjIxNS4xNjguNjQgAylbgWyjEvpjFZZEyH1_Hz6BbvKWuzbceyL5pA2aZOENZG5zLmR1dDA6MzAwMAovZG5zLXF1ZXJ5

Step 5: Set the following configuration in DUT1:

set interfaces ethernet eth0 address 10.215.168.65/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server-name DUT0
set service dns proxy static DUT0 stamp 'sdns://AgAAAAAAAAAADTEwLjIxNS4xNjguNjQgAylbgWyjEvpjFZZEyH1_Hz6BbvKWuzbceyL5pA2aZOENZG5zLmR1dDA6MzAwMAovZG5zLXF1ZXJ5'
set service dns static host-name dns.dut0 inet 10.215.168.64
set service ssh
set system certificate trust 'running://CA.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

^(?m)^.*\[DUT0\] OK \(DoH\) - rtt: \d+ms$
Show output
Oct 30 12:21:13.268337 osdx systemd-journald[1716]: Runtime Journal (/run/log/journal/ec1e6df9c86a4e70bec24fbb88487109) is 1.3M, max 9.7M, 8.4M free.
Oct 30 12:21:13.271861 osdx systemd-journald[1716]: Received client request to rotate journal, rotating.
Oct 30 12:21:13.271908 osdx systemd-journald[1716]: Vacuuming done, freed 0B of archived journals from /run/log/journal/ec1e6df9c86a4e70bec24fbb88487109.
Oct 30 12:21:13.281264 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:21:13.696804 osdx osdx-coredump[91448]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:21:13.704124 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:21:14.792974 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:21:14.862157 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.65/24'.
Oct 30 12:21:14.950254 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Oct 30 12:21:15.004533 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service ssh'.
Oct 30 12:21:15.113702 osdx ERROR[91457]: unexpected
                                          Traceback (most recent call last):
                                            File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                          FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:15.115800 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:15.211859 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:21:15.388254 osdx systemd[1]: Starting ssh.service - OpenBSD Secure Shell server...
Oct 30 12:21:15.400431 osdx sshd[91541]: Server listening on 0.0.0.0 port 22.
Oct 30 12:21:15.400622 osdx sshd[91541]: Server listening on :: port 22.
Oct 30 12:21:15.400720 osdx systemd[1]: Started ssh.service - OpenBSD Secure Shell server.
Oct 30 12:21:15.426888 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:21:15.453502 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:21:15.477834 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:21:15.636867 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'ping 10.215.168.64      count 1 size 56 timeout 1'.
Oct 30 12:21:17.847173 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'service dns proxy stamp calculate dns-over-https host-name dns.dut0 host-path /dns-query host-port 3000 ip 10.215.168.64 hash 03295b816ca312fa63159644c87d7f1f3e816ef296bb36dc7b22f9a40d9a64e1'.
Oct 30 12:21:17.984289 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:21:18.045605 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns static host-name dns.dut0 inet 10.215.168.64'.
Oct 30 12:21:18.164400 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set system certificate trust running://CA.crt'.
Oct 30 12:21:18.239729 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy server-name DUT0'.
Oct 30 12:21:18.360117 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 stamp 'sdns://AgAAAAAAAAAADTEwLjIxNS4xNjguNjQgAylbgWyjEvpjFZZEyH1_Hz6BbvKWuzbceyL5pA2aZOENZG5zLmR1dDA6MzAwMAovZG5zLXF1ZXJ5''.
Oct 30 12:21:18.473360 osdx ERROR[91590]: unexpected
                                          Traceback (most recent call last):
                                            File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                          FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:18.479630 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:18.601775 osdx ca-certificates[91616]: Updating certificates in /etc/ssl/certs...
Oct 30 12:21:19.112984 osdx ca-certificates[92622]: 1 added, 0 removed; done.
Oct 30 12:21:19.115909 osdx ca-certificates[92627]: Running hooks in /etc/ca-certificates/update.d...
Oct 30 12:21:19.118628 osdx ca-certificates[92629]: done.
Oct 30 12:21:19.192395 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Oct 30 12:21:19.194115 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:21:19.197308 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:21:19.214940 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:21:19.220288 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] dnscrypt-proxy 2.0.45
Oct 30 12:21:19.220288 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] Network connectivity detected
Oct 30 12:21:19.220288 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] Dropping privileges
Oct 30 12:21:19.222893 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] Network connectivity detected
Oct 30 12:21:19.222893 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] Now listening to 127.0.0.1:53 [UDP]
Oct 30 12:21:19.222893 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] Now listening to 127.0.0.1:53 [TCP]
Oct 30 12:21:19.222893 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] Firefox workaround initialized
Oct 30 12:21:19.222893 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] Loading the set of cloaking rules from [/tmp/tmpvwjexk5i]
Oct 30 12:21:19.383250 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal show | cat'.
Oct 30 12:21:19.509145 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] [DUT0] OK (DoH) - rtt: 132ms
Oct 30 12:21:19.509145 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] Server with the lowest initial latency: DUT0 (rtt: 132ms)
Oct 30 12:21:19.509145 osdx dnscrypt-proxy[92636]: [2024-10-30 12:21:19] [NOTICE] dnscrypt-proxy is ready - live servers: 1

Step 7: Run command show host lookup teldat.com type A at DUT1 and check if output contains the following tokens:

teldat.com has address 10.11.12.13
Show output
;; communications error to ::1#53: connection refused
;; communications error to ::1#53: connection refused
teldat.com has address 10.11.12.13

Server With Upstream DNSCrypt

Description

Configures DUT0 to connect, using DNSCrypt over an upstream server.

Scenario

Step 1: Run command service dns proxy dnscrypt public-key running://dnscrypt.crt at DUT0 and expect this output:

Show output
c3:57:78:1e:f5:72:9f:24:0f:d8:8d:31:91:23:18:5b:e4:8a:6f:c6:8a:06:98:54:e0:08:4d:a9:61:40:a9:5a

Step 2: Set the following configuration in DUT0:

set interfaces ethernet eth0 address 10.215.168.64/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server cert file 'running://dns.dut0.crt'
set service dns proxy server cert key 'running://dns.dut0.key'
set service dns proxy server-name RD
set service dns proxy static RD protocol dns-crypt ip 10.215.168.1
set service dns proxy static RD protocol dns-crypt port 8443
set service dns proxy static RD protocol dns-crypt provider name 2.dnscrypt-cert.remote.dns
set service dns proxy static RD protocol dns-crypt provider public-key 'c3:57:78:1e:f5:72:9f:24:0f:d8:8d:31:91:23:18:5b:e4:8a:6f:c6:8a:06:98:54:e0:08:4d:a9:61:40:a9:5a'
set service dns resolver local
set service dns static host-name teldat.com inet 10.11.12.13
set system certificate trust 'running://remote.dns-server.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Run command system journal show | cat at DUT0 and check if output matches the following regular expressions:

^(?m)^.*\[RD\] OK \(DNSCrypt\) - rtt: \d+ms$
Show output
Oct 30 12:21:25.301264 osdx systemd-journald[1923]: Runtime Journal (/run/log/journal/877522c656344df9b9ad28416f5f036f) is 2.0M, max 15.3M, 13.2M free.
Oct 30 12:21:25.302480 osdx systemd-journald[1923]: Received client request to rotate journal, rotating.
Oct 30 12:21:25.302538 osdx systemd-journald[1923]: Vacuuming done, freed 0B of archived journals from /run/log/journal/877522c656344df9b9ad28416f5f036f.
Oct 30 12:21:25.312434 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:21:25.638709 osdx osdx-coredump[223862]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:21:25.646674 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:21:26.113913 osdx OSDxCLI[101074]: User 'admin' entered the configuration menu.
Oct 30 12:21:26.184211 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.64/24'.
Oct 30 12:21:26.264067 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Oct 30 12:21:26.339313 osdx ERROR[223870]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:26.340212 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:26.446461 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:21:26.559853 osdx cfgd[1636]: [101074]Completed change to active configuration
Oct 30 12:21:26.585478 osdx OSDxCLI[101074]: User 'admin' committed the configuration.
Oct 30 12:21:26.600539 osdx OSDxCLI[101074]: User 'admin' left the configuration menu.
Oct 30 12:21:26.745149 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'ping 10.215.168.1      count 1 size 56 timeout 1'.
Oct 30 12:21:27.787816 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'service dns proxy dnscrypt public-key running://dnscrypt.crt'.
Oct 30 12:21:27.931601 osdx OSDxCLI[101074]: User 'admin' entered the configuration menu.
Oct 30 12:21:27.991702 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set system certificate trust running://remote.dns-server.crt'.
Oct 30 12:21:28.090946 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server-name RD'.
Oct 30 12:21:28.150170 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD protocol dns-crypt ip 10.215.168.1'.
Oct 30 12:21:28.252793 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD protocol dns-crypt port 8443'.
Oct 30 12:21:28.318141 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD protocol dns-crypt provider name 2.dnscrypt-cert.remote.dns'.
Oct 30 12:21:28.420322 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD protocol dns-crypt provider public-key c3:57:78:1e:f5:72:9f:24:0f:d8:8d:31:91:23:18:5b:e4:8a:6f:c6:8a:06:98:54:e0:08:4d:a9:61:40:a9:5a'.
Oct 30 12:21:28.473106 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns resolver local'.
Oct 30 12:21:28.585302 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server cert file 'running://dns.dut0.crt''.
Oct 30 12:21:28.687103 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server cert key 'running://dns.dut0.key''.
Oct 30 12:21:28.769535 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns static host-name teldat.com inet 10.11.12.13'.
Oct 30 12:21:28.902887 osdx ERROR[223986]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:28.904444 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:29.007193 osdx ca-certificates[224013]: Updating certificates in /etc/ssl/certs...
Oct 30 12:21:29.492434 osdx ca-certificates[225017]: 1 added, 0 removed; done.
Oct 30 12:21:29.495555 osdx ca-certificates[225023]: Running hooks in /etc/ca-certificates/update.d...
Oct 30 12:21:29.498210 osdx ca-certificates[225025]: done.
Oct 30 12:21:29.630717 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Oct 30 12:21:29.631875 osdx cfgd[1636]: [101074]Completed change to active configuration
Oct 30 12:21:29.633924 osdx OSDxCLI[101074]: User 'admin' committed the configuration.
Oct 30 12:21:29.654995 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] dnscrypt-proxy 2.0.45
Oct 30 12:21:29.655186 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Network connectivity detected
Oct 30 12:21:29.655279 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Dropping privileges
Oct 30 12:21:29.657210 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Network connectivity detected
Oct 30 12:21:29.657236 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Now listening to 127.0.0.1:53 [UDP]
Oct 30 12:21:29.657236 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Now listening to 127.0.0.1:53 [TCP]
Oct 30 12:21:29.657268 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Now listening to https://[::]:3000/dns-query [DoH]
Oct 30 12:21:29.657268 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Firefox workaround initialized
Oct 30 12:21:29.657268 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Loading the set of cloaking rules from [/tmp/tmpltevejg0]
Oct 30 12:21:29.657747 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] [RD] OK (DNSCrypt) - rtt: 0ms
Oct 30 12:21:29.657747 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] Server with the lowest initial latency: RD (rtt: 0ms)
Oct 30 12:21:29.657815 osdx dnscrypt-proxy[225085]: [2024-10-30 12:21:29] [NOTICE] dnscrypt-proxy is ready - live servers: 1
Oct 30 12:21:29.663423 osdx OSDxCLI[101074]: User 'admin' left the configuration menu.

Step 4: Set the following configuration in DUT1:

set interfaces ethernet eth0 address 10.215.168.65/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server-name DUT0
set service dns proxy static DUT0 protocol dns-over-https hash 03295b816ca312fa63159644c87d7f1f3e816ef296bb36dc7b22f9a40d9a64e1
set service dns proxy static DUT0 protocol dns-over-https host name dns.dut0
set service dns proxy static DUT0 protocol dns-over-https host port 3000
set service dns proxy static DUT0 protocol dns-over-https ip 10.215.168.64
set service dns static host-name dns.dut0 inet 10.215.168.64
set service ssh
set system certificate trust 'running://CA.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 5: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

^(?m)^.*\[DUT0\] OK \(DoH\) - rtt: \d+ms$
Show output
Oct 30 12:21:26.263031 osdx systemd-journald[1716]: Runtime Journal (/run/log/journal/ec1e6df9c86a4e70bec24fbb88487109) is 1.3M, max 9.7M, 8.4M free.
Oct 30 12:21:26.265642 osdx systemd-journald[1716]: Received client request to rotate journal, rotating.
Oct 30 12:21:26.265707 osdx systemd-journald[1716]: Vacuuming done, freed 0B of archived journals from /run/log/journal/ec1e6df9c86a4e70bec24fbb88487109.
Oct 30 12:21:26.272798 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:21:26.698776 osdx osdx-coredump[94255]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:21:26.706464 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:21:27.757041 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:21:27.830891 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.65/24'.
Oct 30 12:21:27.916073 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Oct 30 12:21:27.972045 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service ssh'.
Oct 30 12:21:28.085151 osdx ERROR[94264]: unexpected
                                          Traceback (most recent call last):
                                            File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                          FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:28.089467 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:28.177638 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:21:28.349859 osdx systemd[1]: Starting ssh.service - OpenBSD Secure Shell server...
Oct 30 12:21:28.360980 osdx sshd[94348]: Server listening on 0.0.0.0 port 22.
Oct 30 12:21:28.361162 osdx sshd[94348]: Server listening on :: port 22.
Oct 30 12:21:28.361273 osdx systemd[1]: Started ssh.service - OpenBSD Secure Shell server.
Oct 30 12:21:28.389701 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:21:28.423575 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:21:28.448600 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:21:28.596278 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'ping 10.215.168.64      count 1 size 56 timeout 1'.
Oct 30 12:21:30.859198 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:21:30.920412 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns static host-name dns.dut0 inet 10.215.168.64'.
Oct 30 12:21:31.014369 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set system certificate trust running://CA.crt'.
Oct 30 12:21:31.074672 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy server-name DUT0'.
Oct 30 12:21:31.174221 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https host name dns.dut0'.
Oct 30 12:21:31.244243 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https host port 3000'.
Oct 30 12:21:31.349248 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https ip 10.215.168.64'.
Oct 30 12:21:31.408091 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https hash 03295b816ca312fa63159644c87d7f1f3e816ef296bb36dc7b22f9a40d9a64e1'.
Oct 30 12:21:31.523673 osdx ERROR[94397]: unexpected
                                          Traceback (most recent call last):
                                            File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                          FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:31.525600 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:31.621260 osdx ca-certificates[94424]: Updating certificates in /etc/ssl/certs...
Oct 30 12:21:32.124198 osdx ca-certificates[95429]: 1 added, 0 removed; done.
Oct 30 12:21:32.127234 osdx ca-certificates[95434]: Running hooks in /etc/ca-certificates/update.d...
Oct 30 12:21:32.130071 osdx ca-certificates[95436]: done.
Oct 30 12:21:32.226015 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Oct 30 12:21:32.227973 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:21:32.230322 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:21:32.246453 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:21:32.259115 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] dnscrypt-proxy 2.0.45
Oct 30 12:21:32.259310 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] Network connectivity detected
Oct 30 12:21:32.259369 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] Dropping privileges
Oct 30 12:21:32.261318 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] Network connectivity detected
Oct 30 12:21:32.261361 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] Now listening to 127.0.0.1:53 [UDP]
Oct 30 12:21:32.261361 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] Now listening to 127.0.0.1:53 [TCP]
Oct 30 12:21:32.261361 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] Firefox workaround initialized
Oct 30 12:21:32.261361 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] Loading the set of cloaking rules from [/tmp/tmpzs80o5mt]
Oct 30 12:21:32.400572 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal show | cat'.
Oct 30 12:21:32.546135 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] [DUT0] OK (DoH) - rtt: 142ms
Oct 30 12:21:32.546135 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] Server with the lowest initial latency: DUT0 (rtt: 142ms)
Oct 30 12:21:32.546135 osdx dnscrypt-proxy[95443]: [2024-10-30 12:21:32] [NOTICE] dnscrypt-proxy is ready - live servers: 1

Step 6: Run command show host lookup teldat.com type A at DUT1 and check if output contains the following tokens:

teldat.com has address 10.11.12.13
Show output
;; communications error to ::1#53: connection refused
;; communications error to ::1#53: connection refused
teldat.com has address 10.11.12.13

Server With Upstream DNSCrypt With Stamp

Description

Configures DUT0 to connect, using DNSCrypt over an upstream server (generating a DNS stamp and using it to configure the connection).

Scenario

Step 1: Run command service dns proxy dnscrypt public-key running://dnscrypt.crt at DUT0 and expect this output:

Show output
c3:57:78:1e:f5:72:9f:24:0f:d8:8d:31:91:23:18:5b:e4:8a:6f:c6:8a:06:98:54:e0:08:4d:a9:61:40:a9:5a

Step 2: Run command service dns proxy stamp calculate dns-crypt provider-name 2.dnscrypt-cert.remote.dns provider-key c3:57:78:1e:f5:72:9f:24:0f:d8:8d:31:91:23:18:5b:e4:8a:6f:c6:8a:06:98:54:e0:08:4d:a9:61:40:a9:5a ip 10.215.168.1 port 8443 at DUT0 and expect this output:

Show output
sdns://AQAAAAAAAAAAETEwLjIxNS4xNjguMTo4NDQzIMNXeB71cp8kD9iNMZEjGFvkim_GigaYVOAITalhQKlaGjIuZG5zY3J5cHQtY2VydC5yZW1vdGUuZG5z

Step 3: Set the following configuration in DUT0:

set interfaces ethernet eth0 address 10.215.168.64/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server cert file 'running://dns.dut0.crt'
set service dns proxy server cert key 'running://dns.dut0.key'
set service dns proxy server-name RD
set service dns proxy static RD stamp 'sdns://AQAAAAAAAAAAETEwLjIxNS4xNjguMTo4NDQzIMNXeB71cp8kD9iNMZEjGFvkim_GigaYVOAITalhQKlaGjIuZG5zY3J5cHQtY2VydC5yZW1vdGUuZG5z'
set service dns resolver local
set service dns static host-name teldat.com inet 10.11.12.13
set system certificate trust 'running://remote.dns-server.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Run command system journal show | cat at DUT0 and check if output matches the following regular expressions:

^(?m)^.*\[RD\] OK \(DNSCrypt\) - rtt: \d+ms$
Show output
Oct 30 12:21:38.309105 osdx systemd-journald[1923]: Runtime Journal (/run/log/journal/877522c656344df9b9ad28416f5f036f) is 2.0M, max 15.3M, 13.2M free.
Oct 30 12:21:38.309637 osdx systemd-journald[1923]: Received client request to rotate journal, rotating.
Oct 30 12:21:38.309673 osdx systemd-journald[1923]: Vacuuming done, freed 0B of archived journals from /run/log/journal/877522c656344df9b9ad28416f5f036f.
Oct 30 12:21:38.319139 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:21:38.646388 osdx osdx-coredump[226728]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:21:38.653837 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:21:39.097017 osdx OSDxCLI[101074]: User 'admin' entered the configuration menu.
Oct 30 12:21:39.172688 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.64/24'.
Oct 30 12:21:39.257638 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Oct 30 12:21:39.325900 osdx ERROR[226736]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:39.326539 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:39.445647 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:21:39.544395 osdx cfgd[1636]: [101074]Completed change to active configuration
Oct 30 12:21:39.569925 osdx OSDxCLI[101074]: User 'admin' committed the configuration.
Oct 30 12:21:39.586030 osdx OSDxCLI[101074]: User 'admin' left the configuration menu.
Oct 30 12:21:39.727798 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'ping 10.215.168.1      count 1 size 56 timeout 1'.
Oct 30 12:21:40.760237 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'service dns proxy dnscrypt public-key running://dnscrypt.crt'.
Oct 30 12:21:40.857329 osdx OSDxCLI[101074]: User 'admin' executed a new command: 'service dns proxy stamp calculate dns-crypt provider-name 2.dnscrypt-cert.remote.dns provider-key c3:57:78:1e:f5:72:9f:24:0f:d8:8d:31:91:23:18:5b:e4:8a:6f:c6:8a:06:98:54:e0:08:4d:a9:61:40:a9:5a ip 10.215.168.1 port 8443'.
Oct 30 12:21:41.019902 osdx OSDxCLI[101074]: User 'admin' entered the configuration menu.
Oct 30 12:21:41.079413 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set system certificate trust running://remote.dns-server.crt'.
Oct 30 12:21:41.175089 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server-name RD'.
Oct 30 12:21:41.236933 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy static RD stamp 'sdns://AQAAAAAAAAAAETEwLjIxNS4xNjguMTo4NDQzIMNXeB71cp8kD9iNMZEjGFvkim_GigaYVOAITalhQKlaGjIuZG5zY3J5cHQtY2VydC5yZW1vdGUuZG5z''.
Oct 30 12:21:41.327213 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns resolver local'.
Oct 30 12:21:41.385257 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server cert file 'running://dns.dut0.crt''.
Oct 30 12:21:41.481885 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns proxy server cert key 'running://dns.dut0.key''.
Oct 30 12:21:41.537428 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'set service dns static host-name teldat.com inet 10.11.12.13'.
Oct 30 12:21:41.649445 osdx ERROR[226852]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:41.650588 osdx OSDxCLI[101074]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:41.731906 osdx ca-certificates[226879]: Updating certificates in /etc/ssl/certs...
Oct 30 12:21:42.199571 osdx ca-certificates[227884]: 1 added, 0 removed; done.
Oct 30 12:21:42.202562 osdx ca-certificates[227889]: Running hooks in /etc/ca-certificates/update.d...
Oct 30 12:21:42.205331 osdx ca-certificates[227891]: done.
Oct 30 12:21:42.337912 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Oct 30 12:21:42.339241 osdx cfgd[1636]: [101074]Completed change to active configuration
Oct 30 12:21:42.341152 osdx OSDxCLI[101074]: User 'admin' committed the configuration.
Oct 30 12:21:42.357798 osdx OSDxCLI[101074]: User 'admin' left the configuration menu.
Oct 30 12:21:42.370657 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] dnscrypt-proxy 2.0.45
Oct 30 12:21:42.370876 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Network connectivity detected
Oct 30 12:21:42.370957 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Dropping privileges
Oct 30 12:21:42.373010 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Network connectivity detected
Oct 30 12:21:42.373048 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Now listening to 127.0.0.1:53 [UDP]
Oct 30 12:21:42.373048 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Now listening to 127.0.0.1:53 [TCP]
Oct 30 12:21:42.373048 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Now listening to https://[::]:3000/dns-query [DoH]
Oct 30 12:21:42.373094 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Firefox workaround initialized
Oct 30 12:21:42.373094 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Loading the set of cloaking rules from [/tmp/tmpne5072qz]
Oct 30 12:21:42.373537 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] [RD] OK (DNSCrypt) - rtt: 0ms
Oct 30 12:21:42.373595 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] Server with the lowest initial latency: RD (rtt: 0ms)
Oct 30 12:21:42.373655 osdx dnscrypt-proxy[227951]: [2024-10-30 12:21:42] [NOTICE] dnscrypt-proxy is ready - live servers: 1

Step 5: Run command service dns proxy stamp calculate dns-over-https host-name dns.dut0 host-path /dns-query host-port 3000 ip 10.215.168.64 hash 03295b816ca312fa63159644c87d7f1f3e816ef296bb36dc7b22f9a40d9a64e1 at DUT1 and expect this output:

Show output
sdns://AgAAAAAAAAAADTEwLjIxNS4xNjguNjQgAylbgWyjEvpjFZZEyH1_Hz6BbvKWuzbceyL5pA2aZOENZG5zLmR1dDA6MzAwMAovZG5zLXF1ZXJ5

Step 6: Set the following configuration in DUT1:

set interfaces ethernet eth0 address 10.215.168.65/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server-name DUT0
set service dns proxy static DUT0 stamp 'sdns://AgAAAAAAAAAADTEwLjIxNS4xNjguNjQgAylbgWyjEvpjFZZEyH1_Hz6BbvKWuzbceyL5pA2aZOENZG5zLmR1dDA6MzAwMAovZG5zLXF1ZXJ5'
set service dns static host-name dns.dut0 inet 10.215.168.64
set service ssh
set system certificate trust 'running://CA.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 7: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

^(?m)^.*\[DUT0\] OK \(DoH\) - rtt: \d+ms$
Show output
Oct 30 12:21:38.277903 osdx systemd-journald[1716]: Runtime Journal (/run/log/journal/ec1e6df9c86a4e70bec24fbb88487109) is 1.3M, max 9.7M, 8.4M free.
Oct 30 12:21:38.279679 osdx systemd-journald[1716]: Received client request to rotate journal, rotating.
Oct 30 12:21:38.279738 osdx systemd-journald[1716]: Vacuuming done, freed 0B of archived journals from /run/log/journal/ec1e6df9c86a4e70bec24fbb88487109.
Oct 30 12:21:38.288248 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:21:38.718542 osdx osdx-coredump[97062]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:21:38.727932 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:21:39.742807 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:21:39.807833 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.65/24'.
Oct 30 12:21:39.899103 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Oct 30 12:21:39.951710 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service ssh'.
Oct 30 12:21:40.065625 osdx ERROR[97071]: unexpected
                                          Traceback (most recent call last):
                                            File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                          FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:40.070056 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:40.155685 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:21:40.323953 osdx systemd[1]: Starting ssh.service - OpenBSD Secure Shell server...
Oct 30 12:21:40.335707 osdx sshd[97155]: Server listening on 0.0.0.0 port 22.
Oct 30 12:21:40.335917 osdx sshd[97155]: Server listening on :: port 22.
Oct 30 12:21:40.336037 osdx systemd[1]: Started ssh.service - OpenBSD Secure Shell server.
Oct 30 12:21:40.361985 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:21:40.388020 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:21:40.411845 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:21:40.564675 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'ping 10.215.168.64      count 1 size 56 timeout 1'.
Oct 30 12:21:42.535514 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'service dns proxy stamp calculate dns-over-https host-name dns.dut0 host-path /dns-query host-port 3000 ip 10.215.168.64 hash 03295b816ca312fa63159644c87d7f1f3e816ef296bb36dc7b22f9a40d9a64e1'.
Oct 30 12:21:42.679483 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:21:42.741073 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns static host-name dns.dut0 inet 10.215.168.64'.
Oct 30 12:21:42.844169 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set system certificate trust running://CA.crt'.
Oct 30 12:21:42.896370 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy server-name DUT0'.
Oct 30 12:21:43.002430 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 stamp 'sdns://AgAAAAAAAAAADTEwLjIxNS4xNjguNjQgAylbgWyjEvpjFZZEyH1_Hz6BbvKWuzbceyL5pA2aZOENZG5zLmR1dDA6MzAwMAovZG5zLXF1ZXJ5''.
Oct 30 12:21:43.072179 osdx ERROR[97204]: unexpected
                                          Traceback (most recent call last):
                                            File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                          FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:21:43.074388 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:21:43.194921 osdx ca-certificates[97231]: Updating certificates in /etc/ssl/certs...
Oct 30 12:21:43.649239 osdx ca-certificates[98236]: 1 added, 0 removed; done.
Oct 30 12:21:43.652321 osdx ca-certificates[98241]: Running hooks in /etc/ca-certificates/update.d...
Oct 30 12:21:43.655183 osdx ca-certificates[98243]: done.
Oct 30 12:21:43.732037 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Oct 30 12:21:43.733747 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:21:43.738162 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:21:43.756103 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:21:43.763657 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:43] [NOTICE] dnscrypt-proxy 2.0.45
Oct 30 12:21:43.763878 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:43] [NOTICE] Network connectivity detected
Oct 30 12:21:43.763941 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:43] [NOTICE] Dropping privileges
Oct 30 12:21:43.766131 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:43] [NOTICE] Network connectivity detected
Oct 30 12:21:43.766204 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:43] [NOTICE] Now listening to 127.0.0.1:53 [UDP]
Oct 30 12:21:43.766204 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:43] [NOTICE] Now listening to 127.0.0.1:53 [TCP]
Oct 30 12:21:43.766204 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:43] [NOTICE] Firefox workaround initialized
Oct 30 12:21:43.766204 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:43] [NOTICE] Loading the set of cloaking rules from [/tmp/tmpw7bwi9fk]
Oct 30 12:21:43.928697 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal show | cat'.
Oct 30 12:21:44.058436 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:44] [NOTICE] [DUT0] OK (DoH) - rtt: 143ms
Oct 30 12:21:44.058436 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:44] [NOTICE] Server with the lowest initial latency: DUT0 (rtt: 143ms)
Oct 30 12:21:44.058436 osdx dnscrypt-proxy[98250]: [2024-10-30 12:21:44] [NOTICE] dnscrypt-proxy is ready - live servers: 1

Step 8: Run command show host lookup teldat.com type A at DUT1 and check if output contains the following tokens:

teldat.com has address 10.11.12.13
Show output
;; communications error to ::1#53: connection refused
;; communications error to ::1#53: connection refused
teldat.com has address 10.11.12.13