Relay

This scenario shows how to configure service dhcp-relay. The relay agent must be used when the DHCP server and the DHCP clients are not connected to the same layer 2 domain.

../../../_images/toplogy.svg

Test DHCP Relay

Description

This example demonstrates how to configure a DHCP relay instance in DUT0 to forward DHCP requests from DUT2 to DUT1.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.225 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.225/0.225/0.225/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Giaddr

Description

This example demonstrates how to set the gateway IP address (giaddr) in the IP address. This value must be set in an IP address that the DHCP server can reach.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.3/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1 giaddr 20.0.0.3
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.264 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.264/0.264/0.264/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.3
Show output
Dec 03 12:57:56.282139 osdx systemd-journald[1705]: Runtime Journal (/run/log/journal/7b9b4b4f707a49f795f87bcc6955a259) is 1.3M, max 9.7M, 8.4M free.
Dec 03 12:57:56.282547 osdx systemd-journald[1705]: Received client request to rotate journal, rotating.
Dec 03 12:57:56.282578 osdx systemd-journald[1705]: Vacuuming done, freed 0B of archived journals from /run/log/journal/7b9b4b4f707a49f795f87bcc6955a259.
Dec 03 12:57:56.292088 osdx OSDxCLI[1924]: User 'admin' executed a new command: 'system journal clear'.
Dec 03 12:57:56.782081 osdx osdx-coredump[22577]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Dec 03 12:57:56.790043 osdx OSDxCLI[1924]: User 'admin' executed a new command: 'system coredump delete all'.
Dec 03 12:57:58.507472 osdx OSDxCLI[1924]: User 'admin' entered the configuration menu.
Dec 03 12:57:58.629200 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Dec 03 12:57:58.696865 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Dec 03 12:57:58.833233 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Dec 03 12:57:58.892701 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Dec 03 12:57:59.024908 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'show working'.
Dec 03 12:57:59.126197 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Dec 03 12:57:59.161777 osdx (udev-worker)[22653]: Network interface NamePolicy= disabled on kernel command line.
Dec 03 12:57:59.326579 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Dec 03 12:57:59.329115 osdx dhcpd[22673]: Wrote 0 leases to leases file.
Dec 03 12:57:59.330633 osdx cfgd[1418]: [1924]Completed change to active configuration
Dec 03 12:57:59.363799 osdx OSDxCLI[1924]: User 'admin' committed the configuration.
Dec 03 12:57:59.378411 osdx dhcpd[22673]:
Dec 03 12:57:59.378417 osdx dhcpd[22673]: No subnet declaration for eth0 (no IPv4 addresses).
Dec 03 12:57:59.378420 osdx dhcpd[22673]: ** Ignoring requests on eth0.  If this is not what
Dec 03 12:57:59.378424 osdx dhcpd[22673]:    you want, please write a subnet declaration
Dec 03 12:57:59.378426 osdx dhcpd[22673]:    in your dhcpd.conf file for the network segment
Dec 03 12:57:59.378429 osdx dhcpd[22673]:    to which interface eth0 is attached. **
Dec 03 12:57:59.378432 osdx dhcpd[22673]:
Dec 03 12:57:59.381401 osdx OSDxCLI[1924]: User 'admin' left the configuration menu.
Dec 03 12:57:59.394299 osdx dhcpd[22673]: Server starting service.
Dec 03 12:57:59.935579 osdx dhcpd[22673]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.3
Dec 03 12:58:00.935995 osdx dhcpd[22673]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
Dec 03 12:58:00.936761 osdx dhcpd[22673]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
Dec 03 12:58:00.993612 osdx dhcpd[22673]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3

Test DHCP Relay With GRE Tunnel

Description

This example demonstrates how to configure a DHCP relay that forwards DHCP requests to the DHCP server through a GRE tunnel (upstream).

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces tunnel tun1 address 1.0.0.2/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.2
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp holdtime 5
set interfaces tunnel tun1 nhrp nhs 1.0.0.1 nbma 10.0.0.1
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 1.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS upstream-interface tun1
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces tunnel tun1 address 1.0.0.1/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.1
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set protocols static route 20.0.0.0/24 next-hop 1.0.0.2
set service dhcp-server shared-network dummy subnet 1.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.271 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.271/0.271/0.271/0.000 ms

Step 5: Ping IP address 1.0.0.1 from DUT0:

admin@DUT0$ ping 1.0.0.1 count 1 size 56 timeout 1
Show output
PING 1.0.0.1 (1.0.0.1) 56(84) bytes of data.
64 bytes from 1.0.0.1: icmp_seq=1 ttl=64 time=0.292 ms

--- 1.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.292/0.292/0.292/0.000 ms

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Multiple Instances

Description

This example demonstrates how to configure multiple DHCP relay instances.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 300 address 30.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS2 downstream-interface eth1.300
set service dhcp-relay INS2 server 10.0.0.1
set service dhcp-relay INS2 upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set interfaces ethernet eth0 vif 300 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.254 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.254/0.254/0.254/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

30.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 7: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.2
DHCPACK on 30.0.0.50 to [^\)]+\) via 30.0.0.2
Show output
Dec 03 12:58:27.294541 osdx systemd-journald[1705]: Runtime Journal (/run/log/journal/7b9b4b4f707a49f795f87bcc6955a259) is 1.3M, max 9.7M, 8.4M free.
Dec 03 12:58:27.298227 osdx systemd-journald[1705]: Received client request to rotate journal, rotating.
Dec 03 12:58:27.298300 osdx systemd-journald[1705]: Vacuuming done, freed 0B of archived journals from /run/log/journal/7b9b4b4f707a49f795f87bcc6955a259.
Dec 03 12:58:27.304547 osdx OSDxCLI[1924]: User 'admin' executed a new command: 'system journal clear'.
Dec 03 12:58:27.812487 osdx osdx-coredump[23258]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Dec 03 12:58:27.822556 osdx OSDxCLI[1924]: User 'admin' executed a new command: 'system coredump delete all'.
Dec 03 12:58:30.024426 osdx OSDxCLI[1924]: User 'admin' entered the configuration menu.
Dec 03 12:58:30.140991 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Dec 03 12:58:30.206494 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Dec 03 12:58:30.306316 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Dec 03 12:58:30.386230 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Dec 03 12:58:30.484412 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50'.
Dec 03 12:58:30.562096 osdx OSDxCLI[1924]: User 'admin' added a new cfg line: 'show working'.
Dec 03 12:58:30.726258 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Dec 03 12:58:30.760788 osdx (udev-worker)[23333]: Network interface NamePolicy= disabled on kernel command line.
Dec 03 12:58:30.902724 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Dec 03 12:58:30.905132 osdx cfgd[1418]: [1924]Completed change to active configuration
Dec 03 12:58:30.907535 osdx dhcpd[23354]: Wrote 0 leases to leases file.
Dec 03 12:58:30.935339 osdx OSDxCLI[1924]: User 'admin' committed the configuration.
Dec 03 12:58:30.947133 osdx dhcpd[23354]:
Dec 03 12:58:30.947140 osdx dhcpd[23354]: No subnet declaration for eth0 (no IPv4 addresses).
Dec 03 12:58:30.947143 osdx dhcpd[23354]: ** Ignoring requests on eth0.  If this is not what
Dec 03 12:58:30.947145 osdx dhcpd[23354]:    you want, please write a subnet declaration
Dec 03 12:58:30.947148 osdx dhcpd[23354]:    in your dhcpd.conf file for the network segment
Dec 03 12:58:30.947151 osdx dhcpd[23354]:    to which interface eth0 is attached. **
Dec 03 12:58:30.947153 osdx dhcpd[23354]:
Dec 03 12:58:30.958315 osdx dhcpd[23354]: Server starting service.
Dec 03 12:58:30.973113 osdx OSDxCLI[1924]: User 'admin' left the configuration menu.
Dec 03 12:58:31.763742 osdx dhcpd[23354]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Dec 03 12:58:31.935465 osdx dhcpd[23354]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 30.0.0.2
Dec 03 12:58:32.764047 osdx dhcpd[23354]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Dec 03 12:58:32.764840 osdx dhcpd[23354]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Dec 03 12:58:32.786294 osdx dhcpd[23354]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Dec 03 12:58:32.935745 osdx dhcpd[23354]: DHCPOFFER on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
Dec 03 12:58:32.936538 osdx dhcpd[23354]: DHCPREQUEST for 30.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
Dec 03 12:58:32.975455 osdx dhcpd[23354]: DHCPACK on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2