Relay

This scenario shows how to configure service dhcp-relay. The relay agent must be used when the DHCP server and the DHCP clients are not connected to the same layer 2 domain.

../../../_images/toplogy.svg

Test DHCP Relay

Description

This example demonstrates how to configure a DHCP relay instance in DUT0 to forward DHCP requests from DUT2 to DUT1.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=2.92 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 2.920/2.920/2.920/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Giaddr

Description

This example demonstrates how to set the gateway IP address (giaddr) in the IP address. This value must be set in an IP address that the DHCP server can reach.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.3/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1 giaddr 20.0.0.3
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.343 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.343/0.343/0.343/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.3
Show output
Feb 03 12:19:05.454410 osdx systemd-journald[1718]: Runtime Journal (/run/log/journal/c2388425c8a74bb4bfb70a762bcfe315) is 2.4M, max 9.7M, 7.3M free.
Feb 03 12:19:05.455829 osdx systemd-journald[1718]: Received client request to rotate journal, rotating.
Feb 03 12:19:05.455923 osdx systemd-journald[1718]: Vacuuming done, freed 0B of archived journals from /run/log/journal/c2388425c8a74bb4bfb70a762bcfe315.
Feb 03 12:19:05.473866 osdx OSDxCLI[1937]: User 'admin' executed a new command: 'system journal clear'.
Feb 03 12:19:06.193007 osdx osdx-coredump[83875]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Feb 03 12:19:06.220314 osdx OSDxCLI[1937]: User 'admin' executed a new command: 'system coredump delete all'.
Feb 03 12:19:09.469415 osdx OSDxCLI[1937]: User 'admin' entered the configuration menu.
Feb 03 12:19:09.590177 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Feb 03 12:19:09.708093 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Feb 03 12:19:09.844356 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Feb 03 12:19:09.957080 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Feb 03 12:19:10.142176 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'show working'.
Feb 03 12:19:10.310043 osdx INFO[83900]: FRR daemons did not change
Feb 03 12:19:10.331698 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Feb 03 12:19:10.374353 osdx (udev-worker)[83944]: Network interface NamePolicy= disabled on kernel command line.
Feb 03 12:19:10.584231 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Feb 03 12:19:10.587362 osdx cfgd[1427]: [1937]Completed change to active configuration
Feb 03 12:19:10.589880 osdx dhcpd[83970]: Wrote 0 leases to leases file.
Feb 03 12:19:10.633906 osdx OSDxCLI[1937]: User 'admin' committed the configuration.
Feb 03 12:19:10.650793 osdx dhcpd[83970]:
Feb 03 12:19:10.650801 osdx dhcpd[83970]: No subnet declaration for eth0 (no IPv4 addresses).
Feb 03 12:19:10.650806 osdx dhcpd[83970]: ** Ignoring requests on eth0.  If this is not what
Feb 03 12:19:10.650810 osdx dhcpd[83970]:    you want, please write a subnet declaration
Feb 03 12:19:10.650813 osdx dhcpd[83970]:    in your dhcpd.conf file for the network segment
Feb 03 12:19:10.650817 osdx dhcpd[83970]:    to which interface eth0 is attached. **
Feb 03 12:19:10.650821 osdx dhcpd[83970]:
Feb 03 12:19:10.659857 osdx dhcpd[83970]: Server starting service.
Feb 03 12:19:10.674336 osdx OSDxCLI[1937]: User 'admin' left the configuration menu.
Feb 03 12:19:11.578918 osdx dhcpd[83970]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.3
Feb 03 12:19:12.579146 osdx dhcpd[83970]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
Feb 03 12:19:12.584148 osdx dhcpd[83970]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
Feb 03 12:19:12.607040 osdx dhcpd[83970]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3

Test DHCP Relay With GRE Tunnel

Description

This example demonstrates how to configure a DHCP relay that forwards DHCP requests to the DHCP server through a GRE tunnel (upstream).

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces tunnel tun1 address 1.0.0.2/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.2
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp holdtime 5
set interfaces tunnel tun1 nhrp nhs 1.0.0.1 nbma 10.0.0.1
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 1.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS upstream-interface tun1
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces tunnel tun1 address 1.0.0.1/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.1
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set protocols static route 20.0.0.0/24 next-hop 1.0.0.2
set service dhcp-server shared-network dummy subnet 1.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.305 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.305/0.305/0.305/0.000 ms

Step 5: Ping IP address 1.0.0.1 from DUT0:

admin@DUT0$ ping 1.0.0.1 count 1 size 56 timeout 1
Show output
PING 1.0.0.1 (1.0.0.1) 56(84) bytes of data.
64 bytes from 1.0.0.1: icmp_seq=1 ttl=64 time=0.413 ms

--- 1.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.413/0.413/0.413/0.000 ms

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Multiple Instances

Description

This example demonstrates how to configure multiple DHCP relay instances.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 300 address 30.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS2 downstream-interface eth1.300
set service dhcp-relay INS2 server 10.0.0.1
set service dhcp-relay INS2 upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set interfaces ethernet eth0 vif 300 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.322 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.322/0.322/0.322/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

30.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 7: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.2
DHCPACK on 30.0.0.50 to [^\)]+\) via 30.0.0.2
Show output
Feb 03 12:19:41.491243 osdx systemd-journald[1718]: Runtime Journal (/run/log/journal/c2388425c8a74bb4bfb70a762bcfe315) is 1.3M, max 9.7M, 8.4M free.
Feb 03 12:19:41.494611 osdx systemd-journald[1718]: Received client request to rotate journal, rotating.
Feb 03 12:19:41.494727 osdx systemd-journald[1718]: Vacuuming done, freed 0B of archived journals from /run/log/journal/c2388425c8a74bb4bfb70a762bcfe315.
Feb 03 12:19:41.510804 osdx OSDxCLI[1937]: User 'admin' executed a new command: 'system journal clear'.
Feb 03 12:19:42.369290 osdx osdx-coredump[84568]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Feb 03 12:19:42.380990 osdx OSDxCLI[1937]: User 'admin' executed a new command: 'system coredump delete all'.
Feb 03 12:19:45.362765 osdx OSDxCLI[1937]: User 'admin' entered the configuration menu.
Feb 03 12:19:45.516739 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Feb 03 12:19:45.631841 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Feb 03 12:19:45.765195 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Feb 03 12:19:45.885195 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Feb 03 12:19:45.994294 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50'.
Feb 03 12:19:46.140955 osdx OSDxCLI[1937]: User 'admin' added a new cfg line: 'show working'.
Feb 03 12:19:46.356539 osdx INFO[84597]: FRR daemons did not change
Feb 03 12:19:46.382606 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Feb 03 12:19:46.444191 osdx (udev-worker)[84646]: Network interface NamePolicy= disabled on kernel command line.
Feb 03 12:19:46.639341 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Feb 03 12:19:46.642058 osdx cfgd[1427]: [1937]Completed change to active configuration
Feb 03 12:19:46.644312 osdx dhcpd[84667]: Wrote 0 leases to leases file.
Feb 03 12:19:46.688420 osdx OSDxCLI[1937]: User 'admin' committed the configuration.
Feb 03 12:19:46.691631 osdx dhcpd[84667]:
Feb 03 12:19:46.691637 osdx dhcpd[84667]: No subnet declaration for eth0 (no IPv4 addresses).
Feb 03 12:19:46.691641 osdx dhcpd[84667]: ** Ignoring requests on eth0.  If this is not what
Feb 03 12:19:46.691644 osdx dhcpd[84667]:    you want, please write a subnet declaration
Feb 03 12:19:46.691646 osdx dhcpd[84667]:    in your dhcpd.conf file for the network segment
Feb 03 12:19:46.691649 osdx dhcpd[84667]:    to which interface eth0 is attached. **
Feb 03 12:19:46.691652 osdx dhcpd[84667]:
Feb 03 12:19:46.706805 osdx dhcpd[84667]: Server starting service.
Feb 03 12:19:46.718041 osdx OSDxCLI[1937]: User 'admin' left the configuration menu.
Feb 03 12:19:47.750524 osdx dhcpd[84667]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Feb 03 12:19:47.977562 osdx dhcpd[84667]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 30.0.0.2
Feb 03 12:19:48.751052 osdx dhcpd[84667]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Feb 03 12:19:48.751959 osdx dhcpd[84667]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Feb 03 12:19:48.798046 osdx dhcpd[84667]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Feb 03 12:19:48.977870 osdx dhcpd[84667]: DHCPOFFER on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
Feb 03 12:19:48.978772 osdx dhcpd[84667]: DHCPREQUEST for 30.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
Feb 03 12:19:49.031366 osdx dhcpd[84667]: DHCPACK on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2