Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.176 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.176/0.176/0.176/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Jan 10 13:47:03.266349 osdx systemd-journald[1523]: Runtime Journal (/run/log/journal/7179cccd71d140d8bcd6364001e8f483) is 992.0K, max 7.2M, 6.2M free.
Jan 10 13:47:03.267272 osdx systemd-journald[1523]: Received client request to rotate journal, rotating.
Jan 10 13:47:03.267318 osdx systemd-journald[1523]: Vacuuming done, freed 0B of archived journals from /run/log/journal/7179cccd71d140d8bcd6364001e8f483.
Jan 10 13:47:03.275604 osdx OSDxCLI[1768]: User 'admin' executed a new command: 'system journal clear'.
Jan 10 13:47:03.699282 osdx osdx-coredump[95434]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Jan 10 13:47:03.708138 osdx OSDxCLI[1768]: User 'admin' executed a new command: 'system coredump delete all'.
Jan 10 13:47:05.209785 osdx OSDxCLI[1768]: User 'admin' entered the configuration menu.
Jan 10 13:47:05.283795 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Jan 10 13:47:05.369896 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Jan 10 13:47:05.431993 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Jan 10 13:47:05.522381 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Jan 10 13:47:05.585322 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Jan 10 13:47:05.676873 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Jan 10 13:47:05.735128 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Jan 10 13:47:05.827923 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Jan 10 13:47:05.880882 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Jan 10 13:47:05.994013 osdx OSDxCLI[1768]: User 'admin' added a new cfg line: 'show working'.
Jan 10 13:47:06.131556 osdx INFO[95482]: FRR daemons did not change
Jan 10 13:47:06.151026 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Jan 10 13:47:06.175683 osdx (udev-worker)[95531]: Network interface NamePolicy= disabled on kernel command line.
Jan 10 13:47:06.659309 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Jan 10 13:47:06.661020 osdx cfgd[1231]: [1768]Completed change to active configuration
Jan 10 13:47:06.662676 osdx dhcpd[95581]: Wrote 0 leases to leases file.
Jan 10 13:47:06.686921 osdx OSDxCLI[1768]: User 'admin' committed the configuration.
Jan 10 13:47:06.694778 osdx dhcpd[95581]:
Jan 10 13:47:06.694784 osdx dhcpd[95581]: No subnet declaration for eth0 (no IPv4 addresses).
Jan 10 13:47:06.694787 osdx dhcpd[95581]: ** Ignoring requests on eth0.  If this is not what
Jan 10 13:47:06.694790 osdx dhcpd[95581]:    you want, please write a subnet declaration
Jan 10 13:47:06.694793 osdx dhcpd[95581]:    in your dhcpd.conf file for the network segment
Jan 10 13:47:06.694796 osdx dhcpd[95581]:    to which interface eth0 is attached. **
Jan 10 13:47:06.694799 osdx dhcpd[95581]:
Jan 10 13:47:06.714393 osdx OSDxCLI[1768]: User 'admin' left the configuration menu.
Jan 10 13:47:06.719144 osdx dhcpd[95581]: Server starting service.
Jan 10 13:47:07.258063 osdx dhcpd[95581]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Jan 10 13:47:07.258999 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=64678 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Jan 10 13:47:08.258218 osdx dhcpd[95581]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Jan 10 13:47:08.259438 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=64810 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Jan 10 13:47:08.259421 osdx dhcpd[95581]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Jan 10 13:47:08.288492 osdx dhcpd[95581]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2