Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.329 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.329/0.329/0.329/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Feb 19 21:20:57.543423 osdx systemd-journald[1550]: Runtime Journal (/run/log/journal/ee06d3e1f21747438cc5b4c977b7f07b) is 1.0M, max 7.2M, 6.2M free.
Feb 19 21:20:57.544856 osdx systemd-journald[1550]: Received client request to rotate journal, rotating.
Feb 19 21:20:57.544957 osdx systemd-journald[1550]: Vacuuming done, freed 0B of archived journals from /run/log/journal/ee06d3e1f21747438cc5b4c977b7f07b.
Feb 19 21:20:57.563166 osdx OSDxCLI[135601]: User 'admin' executed a new command: 'system journal clear'.
Feb 19 21:20:58.560588 osdx osdx-coredump[248675]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Feb 19 21:20:58.585277 osdx OSDxCLI[135601]: User 'admin' executed a new command: 'system coredump delete all'.
Feb 19 21:21:02.257168 osdx OSDxCLI[135601]: User 'admin' entered the configuration menu.
Feb 19 21:21:02.454001 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Feb 19 21:21:02.572122 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Feb 19 21:21:02.762486 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Feb 19 21:21:02.952593 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Feb 19 21:21:03.090721 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Feb 19 21:21:03.231111 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Feb 19 21:21:03.411302 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Feb 19 21:21:03.565658 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Feb 19 21:21:03.772763 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Feb 19 21:21:04.029434 osdx OSDxCLI[135601]: User 'admin' added a new cfg line: 'show working'.
Feb 19 21:21:04.377393 osdx INFO[248730]: FRR daemons did not change
Feb 19 21:21:04.448741 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Feb 19 21:21:04.526271 osdx (udev-worker)[248782]: Network interface NamePolicy= disabled on kernel command line.
Feb 19 21:21:05.017811 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Feb 19 21:21:05.028477 osdx cfgd[1251]: [135601]Completed change to active configuration
Feb 19 21:21:05.093739 osdx OSDxCLI[135601]: User 'admin' committed the configuration.
Feb 19 21:21:05.145964 osdx dhcpd[248823]: Wrote 0 leases to leases file.
Feb 19 21:21:05.152059 osdx OSDxCLI[135601]: User 'admin' left the configuration menu.
Feb 19 21:21:05.209960 osdx dhcpd[248823]:
Feb 19 21:21:05.209974 osdx dhcpd[248823]: No subnet declaration for eth0 (no IPv4 addresses).
Feb 19 21:21:05.209978 osdx dhcpd[248823]: ** Ignoring requests on eth0.  If this is not what
Feb 19 21:21:05.209982 osdx dhcpd[248823]:    you want, please write a subnet declaration
Feb 19 21:21:05.209986 osdx dhcpd[248823]:    in your dhcpd.conf file for the network segment
Feb 19 21:21:05.209991 osdx dhcpd[248823]:    to which interface eth0 is attached. **
Feb 19 21:21:05.209995 osdx dhcpd[248823]:
Feb 19 21:21:05.228880 osdx dhcpd[248823]: Server starting service.
Feb 19 21:21:06.210593 osdx dhcpd[248823]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Feb 19 21:21:06.212655 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=50018 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Feb 19 21:21:07.211261 osdx dhcpd[248823]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Feb 19 21:21:07.212164 osdx dhcpd[248823]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Feb 19 21:21:07.212615 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=50185 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Feb 19 21:21:07.238907 osdx dhcpd[248823]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2