Cipher Server

Test suite to validate using one or multiple ciphers to protect DoH connection

TLS v1.3 Connection

Description

Sets up the DUT0 as a server, DUT1 as a client and ensures the communication between them is secured by TLS v1.3.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address 10.215.168.64/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server cert file 'running://dns.dut0.crt'
set service dns proxy server cert key 'running://dns.dut0.key'
set service dns proxy server-name RD
set service dns proxy static RD protocol dns-over-https hash 3c15e90bd022a1619161d18b235841fbb951fd9251cbf16baaf9244baed3a840
set service dns proxy static RD protocol dns-over-https host name remote.dns
set service dns proxy static RD protocol dns-over-https ip 10.215.168.1
set service dns static host-name teldat.com inet 10.11.12.13
set system certificate trust 'running://remote.dns-server.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.215.168.65/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy log level 0
set service dns proxy server-name DUT0
set service dns proxy static DUT0 protocol dns-over-https hash d4383caf9ab77e95a6b8a98a780cd66bf654ca44184913db3665c41418c643fd
set service dns proxy static DUT0 protocol dns-over-https host name dns.dut0
set service dns proxy static DUT0 protocol dns-over-https host port 3000
set service dns proxy static DUT0 protocol dns-over-https ip 10.215.168.64
set service dns resolver local
set service dns static host-name dns.dut0 inet 10.215.168.64
set service ssh
set system certificate trust 'running://CA.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Run command system journal show | cat at DUT1 and expect this output:

Show output
Feb 19 17:22:14.445994 osdx systemd-journald[1553]: Runtime Journal (/run/log/journal/4ae5be8e493042ac8988aa43cad7f38b) is 1004.0K, max 7.2M, 6.2M free.
Feb 19 17:22:14.447324 osdx systemd-journald[1553]: Received client request to rotate journal, rotating.
Feb 19 17:22:14.447407 osdx systemd-journald[1553]: Vacuuming done, freed 0B of archived journals from /run/log/journal/4ae5be8e493042ac8988aa43cad7f38b.
Feb 19 17:22:14.463687 osdx OSDxCLI[1795]: User 'admin' executed a new command: 'system journal clear'.
Feb 19 17:22:15.245328 osdx osdx-coredump[107830]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Feb 19 17:22:15.260150 osdx OSDxCLI[1795]: User 'admin' executed a new command: 'system coredump delete all'.
Feb 19 17:22:17.572468 osdx OSDxCLI[1795]: User 'admin' entered the configuration menu.
Feb 19 17:22:17.725590 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.65/24'.
Feb 19 17:22:17.838977 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
Feb 19 17:22:17.942635 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service ssh'.
Feb 19 17:22:18.121706 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'show working'.
Feb 19 17:22:18.265373 osdx INFO[107861]: FRR daemons did not change
Feb 19 17:22:18.302992 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Feb 19 17:22:18.664191 osdx systemd[1]: Starting ssh.service - OpenBSD Secure Shell server...
Feb 19 17:22:18.683644 osdx sshd[107931]: Server listening on 0.0.0.0 port 22.
Feb 19 17:22:18.683932 osdx sshd[107931]: Server listening on :: port 22.
Feb 19 17:22:18.684137 osdx systemd[1]: Started ssh.service - OpenBSD Secure Shell server.
Feb 19 17:22:18.719173 osdx cfgd[96903]: [1795]Completed change to active configuration
Feb 19 17:22:18.763486 osdx OSDxCLI[1795]: User 'admin' committed the configuration.
Feb 19 17:22:18.814149 osdx OSDxCLI[1795]: User 'admin' left the configuration menu.
Feb 19 17:22:19.080054 osdx OSDxCLI[1795]: User 'admin' executed a new command: 'ping 10.215.168.64 count 1 size 56 timeout 1'.
Feb 19 17:22:22.775012 osdx OSDxCLI[1795]: User 'admin' entered the configuration menu.
Feb 19 17:22:22.932332 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service dns static host-name dns.dut0 inet 10.215.168.64'.
Feb 19 17:22:23.101315 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set system certificate trust running://CA.crt'.
Feb 19 17:22:23.263638 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service dns proxy server-name DUT0'.
Feb 19 17:22:23.415824 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https host name dns.dut0'.
Feb 19 17:22:23.548845 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https host port 3000'.
Feb 19 17:22:23.743582 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https ip 10.215.168.64'.
Feb 19 17:22:23.949288 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https hash d4383caf9ab77e95a6b8a98a780cd66bf654ca44184913db3665c41418c643fd'.
Feb 19 17:22:24.093443 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service dns proxy log level 0'.
Feb 19 17:22:24.247575 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'set service dns resolver local'.
Feb 19 17:22:24.393263 osdx OSDxCLI[1795]: User 'admin' added a new cfg line: 'show working'.
Feb 19 17:22:24.578177 osdx INFO[107994]: FRR daemons did not change
Feb 19 17:22:24.623412 osdx ca-certificates[108010]: Updating certificates in /etc/ssl/certs...
Feb 19 17:22:25.919341 osdx ca-certificates[109012]: 1 added, 0 removed; done.
Feb 19 17:22:25.925940 osdx ca-certificates[109020]: Running hooks in /etc/ca-certificates/update.d...
Feb 19 17:22:25.932058 osdx ca-certificates[109022]: done.
Feb 19 17:22:26.171977 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
Feb 19 17:22:26.183280 osdx cfgd[96903]: [1795]Completed change to active configuration
Feb 19 17:22:26.196496 osdx OSDxCLI[1795]: User 'admin' committed the configuration.
Feb 19 17:22:26.252538 osdx OSDxCLI[1795]: User 'admin' left the configuration menu.
Feb 19 17:22:26.473083 osdx OSDxCLI[1795]: User 'admin' executed a new command: 'system journal show | cat'.
Feb 19 17:22:26.577573 osdx dnscrypt-proxy[109082]: dnscrypt-proxy 2.0.45
Feb 19 17:22:26.578036 osdx dnscrypt-proxy[109082]: Network connectivity detected
Feb 19 17:22:26.578474 osdx dnscrypt-proxy[109082]: Dropping privileges
Feb 19 17:22:26.582250 osdx dnscrypt-proxy[109082]: Network connectivity detected
Feb 19 17:22:26.582702 osdx dnscrypt-proxy[109082]: Now listening to 127.0.0.1:53 [UDP]
Feb 19 17:22:26.582712 osdx dnscrypt-proxy[109082]: Now listening to 127.0.0.1:53 [TCP]
Feb 19 17:22:26.582745 osdx dnscrypt-proxy[109082]: Firefox workaround initialized
Feb 19 17:22:26.582753 osdx dnscrypt-proxy[109082]: Loading the set of cloaking rules from [/tmp/tmpyy260g6m]
Feb 19 17:22:26.731043 osdx dnscrypt-proxy[109082]: [DUT0] TLS version: 304 - Protocol: h2 - Cipher suite: 4867
Feb 19 17:22:26.731064 osdx dnscrypt-proxy[109082]: [DUT0] OK (DoH) - rtt: 59ms
Feb 19 17:22:26.731076 osdx dnscrypt-proxy[109082]: Server with the lowest initial latency: DUT0 (rtt: 59ms)
Feb 19 17:22:26.731084 osdx dnscrypt-proxy[109082]: dnscrypt-proxy is ready - live servers: 1