Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.254 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.254/0.254/0.254/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Mar 10 12:34:51.313143 osdx systemd-journald[1541]: Runtime Journal (/run/log/journal/37bd014e8df84dd2aee0f9bf8ac2600d) is 1.0M, max 7.2M, 6.2M free.
Mar 10 12:34:51.313501 osdx systemd-journald[1541]: Received client request to rotate journal, rotating.
Mar 10 12:34:51.313533 osdx systemd-journald[1541]: Vacuuming done, freed 0B of archived journals from /run/log/journal/37bd014e8df84dd2aee0f9bf8ac2600d.
Mar 10 12:34:51.322378 osdx OSDxCLI[145235]: User 'admin' executed a new command: 'system journal clear'.
Mar 10 12:34:51.809723 osdx osdx-coredump[204810]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Mar 10 12:34:51.818142 osdx OSDxCLI[145235]: User 'admin' executed a new command: 'system coredump delete all'.
Mar 10 12:34:53.379740 osdx OSDxCLI[145235]: User 'admin' entered the configuration menu.
Mar 10 12:34:53.470975 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Mar 10 12:34:53.581804 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Mar 10 12:34:53.676980 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Mar 10 12:34:53.748630 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Mar 10 12:34:53.860894 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Mar 10 12:34:53.919729 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Mar 10 12:34:54.022667 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Mar 10 12:34:54.122955 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Mar 10 12:34:54.223197 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Mar 10 12:34:54.330628 osdx OSDxCLI[145235]: User 'admin' added a new cfg line: 'show working'.
Mar 10 12:34:54.466819 osdx INFO[204858]: FRR daemons did not change
Mar 10 12:34:54.485423 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Mar 10 12:34:54.514652 osdx (udev-worker)[204908]: Network interface NamePolicy= disabled on kernel command line.
Mar 10 12:34:54.785868 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Mar 10 12:34:54.788080 osdx cfgd[1242]: [145235]Completed change to active configuration
Mar 10 12:34:54.788762 osdx dhcpd[204951]: Wrote 0 leases to leases file.
Mar 10 12:34:54.817953 osdx OSDxCLI[145235]: User 'admin' committed the configuration.
Mar 10 12:34:54.820320 osdx dhcpd[204951]:
Mar 10 12:34:54.820326 osdx dhcpd[204951]: No subnet declaration for eth0 (no IPv4 addresses).
Mar 10 12:34:54.820329 osdx dhcpd[204951]: ** Ignoring requests on eth0.  If this is not what
Mar 10 12:34:54.820332 osdx dhcpd[204951]:    you want, please write a subnet declaration
Mar 10 12:34:54.820335 osdx dhcpd[204951]:    in your dhcpd.conf file for the network segment
Mar 10 12:34:54.820338 osdx dhcpd[204951]:    to which interface eth0 is attached. **
Mar 10 12:34:54.820342 osdx dhcpd[204951]:
Mar 10 12:34:54.837028 osdx OSDxCLI[145235]: User 'admin' left the configuration menu.
Mar 10 12:34:54.837578 osdx dhcpd[204951]: Server starting service.
Mar 10 12:34:55.426470 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=8164 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Mar 10 12:34:55.426385 osdx dhcpd[204951]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Mar 10 12:34:56.426536 osdx dhcpd[204951]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Mar 10 12:34:56.427246 osdx dhcpd[204951]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Mar 10 12:34:56.429422 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=8215 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Mar 10 12:34:56.459133 osdx dhcpd[204951]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2