Relay

This scenario shows how to configure service dhcp-relay. The relay agent must be used when the DHCP server and the DHCP clients are not connected to the same layer 2 domain.

../../../_images/toplogy.svg

Test DHCP Relay

Description

This example demonstrates how to configure a DHCP relay instance in DUT0 to forward DHCP requests from DUT2 to DUT1.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.239 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.239/0.239/0.239/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Giaddr

Description

This example demonstrates how to set the gateway IP address (giaddr) in the IP address. This value must be set in an IP address that the DHCP server can reach.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.3/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1 giaddr 20.0.0.3
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.218 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.218/0.218/0.218/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.3
Show output
May 19 16:33:21.302050 osdx systemd-journald[1727]: Runtime Journal (/run/log/journal/84645c9b514a44e9b4e3e764dfb17349) is 1016.0K, max 7.2M, 6.2M free.
May 19 16:33:21.304869 osdx systemd-journald[1727]: Received client request to rotate journal, rotating.
May 19 16:33:21.304921 osdx systemd-journald[1727]: Vacuuming done, freed 0B of archived journals from /run/log/journal/84645c9b514a44e9b4e3e764dfb17349.
May 19 16:33:21.314804 osdx OSDxCLI[1965]: User 'admin' executed a new command: 'system journal clear'.
May 19 16:33:21.771606 osdx osdx-coredump[121482]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
May 19 16:33:21.779737 osdx OSDxCLI[1965]: User 'admin' executed a new command: 'system coredump delete all'.
May 19 16:33:23.247362 osdx OSDxCLI[1965]: User 'admin' entered the configuration menu.
May 19 16:33:23.333188 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
May 19 16:33:23.416536 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
May 19 16:33:23.480692 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
May 19 16:33:23.577321 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
May 19 16:33:23.649940 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'show working'.
May 19 16:33:23.752573 osdx INFO[121506]: FRR daemons did not change
May 19 16:33:23.772782 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
May 19 16:33:23.795764 osdx (udev-worker)[121557]: Network interface NamePolicy= disabled on kernel command line.
May 19 16:33:23.949122 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
May 19 16:33:23.951907 osdx cfgd[1434]: [1965]Completed change to active configuration
May 19 16:33:23.955331 osdx dhcpd[121579]: Wrote 0 leases to leases file.
May 19 16:33:23.979820 osdx OSDxCLI[1965]: User 'admin' committed the configuration.
May 19 16:33:23.983876 osdx dhcpd[121579]:
May 19 16:33:23.983882 osdx dhcpd[121579]: No subnet declaration for eth0 (no IPv4 addresses).
May 19 16:33:23.983885 osdx dhcpd[121579]: ** Ignoring requests on eth0.  If this is not what
May 19 16:33:23.983888 osdx dhcpd[121579]:    you want, please write a subnet declaration
May 19 16:33:23.983891 osdx dhcpd[121579]:    in your dhcpd.conf file for the network segment
May 19 16:33:23.983894 osdx dhcpd[121579]:    to which interface eth0 is attached. **
May 19 16:33:23.983897 osdx dhcpd[121579]:
May 19 16:33:23.996906 osdx dhcpd[121579]: Server starting service.
May 19 16:33:24.004059 osdx OSDxCLI[1965]: User 'admin' left the configuration menu.
May 19 16:33:24.564143 osdx dhcpd[121579]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.3
May 19 16:33:25.564811 osdx dhcpd[121579]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
May 19 16:33:25.565442 osdx dhcpd[121579]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
May 19 16:33:25.600534 osdx dhcpd[121579]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3

Test DHCP Relay With GRE Tunnel

Description

This example demonstrates how to configure a DHCP relay that forwards DHCP requests to the DHCP server through a GRE tunnel (upstream).

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces tunnel tun1 address 1.0.0.2/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.2
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp holdtime 5
set interfaces tunnel tun1 nhrp nhs 1.0.0.1 nbma 10.0.0.1
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 1.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS upstream-interface tun1
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces tunnel tun1 address 1.0.0.1/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.1
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set protocols static route 20.0.0.0/24 next-hop 1.0.0.2
set service dhcp-server shared-network dummy subnet 1.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.167 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.167/0.167/0.167/0.000 ms

Step 5: Ping IP address 1.0.0.1 from DUT0:

admin@DUT0$ ping 1.0.0.1 count 1 size 56 timeout 1
Show output
PING 1.0.0.1 (1.0.0.1) 56(84) bytes of data.
64 bytes from 1.0.0.1: icmp_seq=1 ttl=64 time=0.260 ms

--- 1.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.260/0.260/0.260/0.000 ms

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Multiple Instances

Description

This example demonstrates how to configure multiple DHCP relay instances.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 300 address 30.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS2 downstream-interface eth1.300
set service dhcp-relay INS2 server 10.0.0.1
set service dhcp-relay INS2 upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set interfaces ethernet eth0 vif 300 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.223 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.223/0.223/0.223/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

30.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 7: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.2
DHCPACK on 30.0.0.50 to [^\)]+\) via 30.0.0.2
Show output
May 19 16:33:50.281843 osdx systemd-journald[1727]: Runtime Journal (/run/log/journal/84645c9b514a44e9b4e3e764dfb17349) is 1.0M, max 7.2M, 6.2M free.
May 19 16:33:50.283689 osdx systemd-journald[1727]: Received client request to rotate journal, rotating.
May 19 16:33:50.283737 osdx systemd-journald[1727]: Vacuuming done, freed 0B of archived journals from /run/log/journal/84645c9b514a44e9b4e3e764dfb17349.
May 19 16:33:50.291257 osdx OSDxCLI[1965]: User 'admin' executed a new command: 'system journal clear'.
May 19 16:33:50.782332 osdx osdx-coredump[122158]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
May 19 16:33:50.790190 osdx OSDxCLI[1965]: User 'admin' executed a new command: 'system coredump delete all'.
May 19 16:33:52.570318 osdx OSDxCLI[1965]: User 'admin' entered the configuration menu.
May 19 16:33:52.646095 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
May 19 16:33:52.741609 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
May 19 16:33:52.818106 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
May 19 16:33:52.929053 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
May 19 16:33:52.997524 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50'.
May 19 16:33:53.116453 osdx OSDxCLI[1965]: User 'admin' added a new cfg line: 'show working'.
May 19 16:33:53.198460 osdx INFO[122185]: FRR daemons did not change
May 19 16:33:53.223717 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
May 19 16:33:53.253838 osdx (udev-worker)[122237]: Network interface NamePolicy= disabled on kernel command line.
May 19 16:33:53.372394 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
May 19 16:33:53.375879 osdx cfgd[1434]: [1965]Completed change to active configuration
May 19 16:33:53.379695 osdx dhcpd[122258]: Wrote 0 leases to leases file.
May 19 16:33:53.405907 osdx OSDxCLI[1965]: User 'admin' committed the configuration.
May 19 16:33:53.425243 osdx OSDxCLI[1965]: User 'admin' left the configuration menu.
May 19 16:33:53.436618 osdx dhcpd[122258]:
May 19 16:33:53.436623 osdx dhcpd[122258]: No subnet declaration for eth0 (no IPv4 addresses).
May 19 16:33:53.436626 osdx dhcpd[122258]: ** Ignoring requests on eth0.  If this is not what
May 19 16:33:53.436628 osdx dhcpd[122258]:    you want, please write a subnet declaration
May 19 16:33:53.436630 osdx dhcpd[122258]:    in your dhcpd.conf file for the network segment
May 19 16:33:53.436633 osdx dhcpd[122258]:    to which interface eth0 is attached. **
May 19 16:33:53.436635 osdx dhcpd[122258]:
May 19 16:33:53.455897 osdx dhcpd[122258]: Server starting service.
May 19 16:33:54.123186 osdx dhcpd[122258]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
May 19 16:33:54.282938 osdx dhcpd[122258]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 30.0.0.2
May 19 16:33:55.123733 osdx dhcpd[122258]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
May 19 16:33:55.124319 osdx dhcpd[122258]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
May 19 16:33:55.150772 osdx dhcpd[122258]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
May 19 16:33:55.283159 osdx dhcpd[122258]: DHCPOFFER on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
May 19 16:33:55.283860 osdx dhcpd[122258]: DHCPREQUEST for 30.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
May 19 16:33:55.322235 osdx dhcpd[122258]: DHCPACK on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2