Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.402 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.402/0.402/0.402/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Mar 21 17:09:58.552303 osdx systemd-journald[1788]: Runtime Journal (/run/log/journal/861e844a51d845da80ca1ef91808d3be) is 1.0M, max 7.2M, 6.1M free.
Mar 21 17:09:58.554375 osdx systemd-journald[1788]: Received client request to rotate journal, rotating.
Mar 21 17:09:58.554502 osdx systemd-journald[1788]: Vacuuming done, freed 0B of archived journals from /run/log/journal/861e844a51d845da80ca1ef91808d3be.
Mar 21 17:09:58.572724 osdx OSDxCLI[2049]: User 'admin' executed a new command: 'system journal clear'.
Mar 21 17:09:59.587413 osdx osdx-coredump[76493]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Mar 21 17:09:59.600319 osdx OSDxCLI[2049]: User 'admin' executed a new command: 'system coredump delete all'.
Mar 21 17:10:03.082635 osdx OSDxCLI[2049]: User 'admin' entered the configuration menu.
Mar 21 17:10:03.272028 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Mar 21 17:10:03.393196 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Mar 21 17:10:03.541981 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Mar 21 17:10:03.665608 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Mar 21 17:10:03.825257 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Mar 21 17:10:03.954848 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Mar 21 17:10:04.113530 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Mar 21 17:10:04.265507 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Mar 21 17:10:04.432152 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Mar 21 17:10:04.752566 osdx OSDxCLI[2049]: User 'admin' added a new cfg line: 'show working'.
Mar 21 17:10:04.890645 osdx ubnt-cfgd[76529]: inactive
Mar 21 17:10:05.086204 osdx INFO[76558]: FRR daemons did not change
Mar 21 17:10:05.117688 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Mar 21 17:10:05.162247 osdx (udev-worker)[76607]: Network interface NamePolicy= disabled on kernel command line.
Mar 21 17:10:05.802983 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Mar 21 17:10:05.809340 osdx cfgd[1473]: [2049]Completed change to active configuration
Mar 21 17:10:05.810362 osdx dhcpd[76701]: Wrote 0 leases to leases file.
Mar 21 17:10:05.836667 osdx OSDxCLI[2049]: User 'admin' committed the configuration.
Mar 21 17:10:05.910645 osdx OSDxCLI[2049]: User 'admin' left the configuration menu.
Mar 21 17:10:05.913537 osdx dhcpd[76701]:
Mar 21 17:10:05.913686 osdx dhcpd[76701]: No subnet declaration for eth0 (no IPv4 addresses).
Mar 21 17:10:05.913773 osdx dhcpd[76701]: ** Ignoring requests on eth0.  If this is not what
Mar 21 17:10:05.913889 osdx dhcpd[76701]:    you want, please write a subnet declaration
Mar 21 17:10:05.914009 osdx dhcpd[76701]:    in your dhcpd.conf file for the network segment
Mar 21 17:10:05.914119 osdx dhcpd[76701]:    to which interface eth0 is attached. **
Mar 21 17:10:05.914195 osdx dhcpd[76701]:
Mar 21 17:10:05.927609 osdx dhcpd[76701]: Server starting service.
Mar 21 17:10:07.620165 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=21986 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Mar 21 17:10:07.620085 osdx dhcpd[76701]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Mar 21 17:10:08.620792 osdx dhcpd[76701]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Mar 21 17:10:08.629199 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=22134 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Mar 21 17:10:08.629657 osdx dhcpd[76701]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Mar 21 17:10:08.656356 osdx dhcpd[76701]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2