Bfd Static Route

Tests to check BFD protocol in static routes.

Test Connection With Next Hop

Description

Checks connection between two devices with BFD in static routes using the gateway as the BFD peer.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address 10.10.0.100/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.200 bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.10.0.200/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.100 bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

peer 10.10.0.200
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.200 (status: uninstalled)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 4: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.100
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.100 (status: uninstalled)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 5: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

peer 10.10.0.200
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 1713907732
                Remote ID: 0
                Active mode
                Status: down
                Downtime: 1 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 6: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.100
Show output
BFD Peers:
        peer 10.10.0.100 vrf default
                ID: 3291351279
                Remote ID: 0
                Active mode
                Status: down
                Downtime: 1 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 7: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.200 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 8: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.100 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 9: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 1713907732
                Remote ID: 3291351279
                Active mode
                Status: up
                Uptime: 1 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 10: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.100 vrf default
                ID: 3291351279
                Remote ID: 1713907732
                Active mode
                Status: up
                Uptime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 11: Ping IP address 10.10.0.200 from DUT0:

admin@DUT0$ ping 10.10.0.200 count 1 size 56 timeout 1
Show output
PING 10.10.0.200 (10.10.0.200) 56(84) bytes of data.
64 bytes from 10.10.0.200: icmp_seq=1 ttl=64 time=0.230 ms

--- 10.10.0.200 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.230/0.230/0.230/0.000 ms

Step 12: Ping IP address 10.10.0.100 from DUT1:

admin@DUT1$ ping 10.10.0.100 count 1 size 56 timeout 1
Show output
PING 10.10.0.100 (10.10.0.100) 56(84) bytes of data.
64 bytes from 10.10.0.100: icmp_seq=1 ttl=64 time=0.223 ms

--- 10.10.0.100 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.223/0.223/0.223/0.000 ms

Test Connection With Next Hop And Interface

Description

Checks connection between two devices with BFD in static routes using the gateway as the BFD peer and an interface.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address 10.10.0.100/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.200 interface eth0 bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.10.0.200/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.100 interface eth0 bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

peer 10.10.0.200
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.200 (status: uninstalled)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 4: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.100
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.100 (status: uninstalled)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 5: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

peer 10.10.0.200
Show output
BFD Peers:
        peer 10.10.0.200 vrf default interface eth0
                ID: 2644993270
                Remote ID: 0
                Active mode
                Status: down
                Downtime: 1 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 6: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.100
Show output
BFD Peers:
        peer 10.10.0.100 vrf default interface eth0
                ID: 3311403727
                Remote ID: 0
                Active mode
                Status: down
                Downtime: 1 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 7: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.200 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 8: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.100 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 9: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.200 vrf default interface eth0
                ID: 2644993270
                Remote ID: 3311403727
                Active mode
                Status: up
                Uptime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 10: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.100 vrf default interface eth0
                ID: 3311403727
                Remote ID: 2644993270
                Active mode
                Status: up
                Uptime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 11: Ping IP address 10.10.0.200 from DUT0:

admin@DUT0$ ping 10.10.0.200 count 1 size 56 timeout 1
Show output
PING 10.10.0.200 (10.10.0.200) 56(84) bytes of data.
64 bytes from 10.10.0.200: icmp_seq=1 ttl=64 time=0.255 ms

--- 10.10.0.200 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.255/0.255/0.255/0.000 ms

Step 12: Ping IP address 10.10.0.100 from DUT1:

admin@DUT1$ ping 10.10.0.100 count 1 size 56 timeout 1
Show output
PING 10.10.0.100 (10.10.0.100) 56(84) bytes of data.
64 bytes from 10.10.0.100: icmp_seq=1 ttl=64 time=0.245 ms

--- 10.10.0.100 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.245/0.245/0.245/0.000 ms

Test Connection With Next Hop And Next Hop VRF

Description

Checks connection between two devices with BFD in static routes using the gateway as the BFD peer and a leaked route with a nexthop in the specified VRF ID.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address 10.10.0.100/24
set interfaces ethernet eth0 vrf VRF
set protocols static route 0.0.0.0/0 next-hop 10.10.0.200 next-hop-vrf VRF bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set system vrf VRF

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.10.0.200/24
set interfaces ethernet eth0 vrf VRF
set protocols static route 0.0.0.0/0 next-hop 10.10.0.100 next-hop-vrf VRF bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set system vrf VRF

Step 3: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

peer 10.10.0.200
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.200 (status: uninstalled)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 4: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.100
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.100 (status: uninstalled)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 5: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

peer 10.10.0.200
Show output
BFD Peers:
        peer 10.10.0.200 vrf VRF
                ID: 978045779
                Remote ID: 0
                Active mode
                Status: down
                Downtime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 6: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.100
Show output
BFD Peers:
        peer 10.10.0.100 vrf VRF
                ID: 1802830020
                Remote ID: 0
                Active mode
                Status: down
                Downtime: 0 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 7: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.200 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 8: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.100 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 9: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.200 vrf VRF
                ID: 978045779
                Remote ID: 1802830020
                Active mode
                Status: up
                Uptime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 10: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.100 vrf VRF
                ID: 1802830020
                Remote ID: 978045779
                Active mode
                Status: up
                Uptime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 11: Ping IP address 10.10.0.200 from DUT0:

admin@DUT0$ ping 10.10.0.200 count 1 size 56 timeout 1
Show output
PING 10.10.0.200 (10.10.0.200) 56(84) bytes of data.
64 bytes from 10.10.0.200: icmp_seq=1 ttl=64 time=0.268 ms

--- 10.10.0.200 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.268/0.268/0.268/0.000 ms

Step 12: Ping IP address 10.10.0.100 from DUT1:

admin@DUT1$ ping 10.10.0.100 count 1 size 56 timeout 1
Show output
PING 10.10.0.100 (10.10.0.100) 56(84) bytes of data.
64 bytes from 10.10.0.100: icmp_seq=1 ttl=64 time=0.229 ms

--- 10.10.0.100 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.229/0.229/0.229/0.000 ms

Test Connection With DHCP Interface

Description

Checks connection between two devices with BFD in static routes using using a DHCP interface that supplies the next-hop IP address.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address dhcp
set protocols static route 0.0.0.0/0 dhcp-interface eth0 bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.10.0.200/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.150 bfd
set service dhcp-server shared-network dhcpserver subnet 10.10.0.0/24 options default-router 10.10.0.200
set service dhcp-server shared-network dhcpserver subnet 10.10.0.0/24 start 10.10.0.150 stop 10.10.0.150
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

peer 10.10.0.200
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.200 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 4: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.150
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.150 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 5: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

peer 10.10.0.200
Show output
BFD Peers:
        peer 10.10.0.200 vrf default interface eth0
                ID: 3868615571
                Remote ID: 1579452760
                Active mode
                Status: up
                Uptime: 0 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 6: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.150
Show output
BFD Peers:
        peer 10.10.0.150 vrf default
                ID: 1579452760
                Remote ID: 3868615571
                Active mode
                Status: up
                Uptime: 1 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 7: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.200 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 8: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        0.0.0.0/0 peer 10.10.0.150 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 9: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.200 vrf default interface eth0
                ID: 3868615571
                Remote ID: 1579452760
                Active mode
                Status: up
                Uptime: 1 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 10: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.150 vrf default
                ID: 1579452760
                Remote ID: 3868615571
                Active mode
                Status: up
                Uptime: 1 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 11: Ping IP address 10.10.0.200 from DUT0:

admin@DUT0$ ping 10.10.0.200 count 1 size 56 timeout 1
Show output
PING 10.10.0.200 (10.10.0.200) 56(84) bytes of data.
64 bytes from 10.10.0.200: icmp_seq=1 ttl=64 time=0.281 ms

--- 10.10.0.200 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.281/0.281/0.281/0.000 ms

Step 12: Ping IP address 10.10.0.150 from DUT1:

admin@DUT1$ ping 10.10.0.150 count 1 size 56 timeout 1
Show output
PING 10.10.0.150 (10.10.0.150) 56(84) bytes of data.
64 bytes from 10.10.0.150: icmp_seq=1 ttl=64 time=0.249 ms

--- 10.10.0.150 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.249/0.249/0.249/0.000 ms

Test Multihop Connection

Description

Checks multihop connection between two devices in different networks

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces dummy dum0 address 1.1.1.1/24
set interfaces ethernet eth0 address 10.10.0.100/24
set protocols static route 2.2.2.0/24 next-hop 20.20.0.200 bfd multihop
set protocols static route 20.20.0.0/24 next-hop 10.10.0.101
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces dummy dum0 address 2.2.2.1/24
set interfaces ethernet eth0 address 20.20.0.200/24
set protocols static route 1.1.1.0/24 next-hop 10.10.0.100 bfd multihop
set protocols static route 10.10.0.0/24 next-hop 20.20.0.201
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 address 10.10.0.101/24
set interfaces ethernet eth1 address 20.20.0.201/24
set protocols static route 1.1.1.0/24 next-hop 10.10.0.100
set protocols static route 2.2.2.0/24 next-hop 20.20.0.200
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

peer 20.20.0.200
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        2.2.2.0/24 peer 20.20.0.200 (status: uninstalled)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 5: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.100
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        1.1.1.0/24 peer 10.10.0.100 (status: uninstalled)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 6: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

peer 20.20.0.200
Show output
BFD Peers:
        peer 20.20.0.200 multihop local-address 10.10.0.100 vrf default
                ID: 2322550268
                Remote ID: 0
                Active mode
                Minimum TTL: 2
                Status: down
                Downtime: 3 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 7: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

peer 10.10.0.100
Show output
BFD Peers:
        peer 10.10.0.100 multihop local-address 20.20.0.200 vrf default
                ID: 465026674
                Remote ID: 2322550268
                Active mode
                Minimum TTL: 2
                Status: init
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: 50ms

Step 8: Run command protocols bfd show static route at DUT0 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        2.2.2.0/24 peer 20.20.0.200 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:

Step 9: Run command protocols bfd show static route at DUT1 and check if output matches the following regular expressions:

status: installed
Show output
Showing BFD monitored static routes:

  Next hops:
    VRF default IPv4 Unicast:
        1.1.1.0/24 peer 10.10.0.100 (status: installed)

    VRF default IPv4 Multicast:

    VRF default IPv6 Unicast:
    VRF tenant1 IPv4 Unicast:

    VRF tenant1 IPv4 Multicast:

    VRF tenant1 IPv6 Unicast:
    VRF tenant2 IPv4 Unicast:

    VRF tenant2 IPv4 Multicast:

    VRF tenant2 IPv6 Unicast:
    VRF tenant3 IPv4 Unicast:

    VRF tenant3 IPv4 Multicast:

    VRF tenant3 IPv6 Unicast:

Step 10: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 20.20.0.200 multihop local-address 10.10.0.100 vrf default
                ID: 2322550268
                Remote ID: 465026674
                Active mode
                Minimum TTL: 2
                Status: up
                Uptime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 11: Run command protocols bfd show peers at DUT1 and check if output matches the following regular expressions:

Status: up
Show output
BFD Peers:
        peer 10.10.0.100 multihop local-address 20.20.0.200 vrf default
                ID: 465026674
                Remote ID: 2322550268
                Active mode
                Minimum TTL: 2
                Status: up
                Uptime: 3 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms
                        Echo transmission interval: disabled
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 300ms
                        Transmission interval: 300ms
                        Echo receive interval: 50ms

Step 12: Ping IP address 20.20.0.200 from DUT0:

admin@DUT0$ ping 20.20.0.200 count 1 size 56 timeout 1
Show output
PING 20.20.0.200 (20.20.0.200) 56(84) bytes of data.
64 bytes from 20.20.0.200: icmp_seq=1 ttl=63 time=0.420 ms

--- 20.20.0.200 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.420/0.420/0.420/0.000 ms

Step 13: Ping IP address 10.10.0.100 from DUT1:

admin@DUT1$ ping 10.10.0.100 count 1 size 56 timeout 1
Show output
PING 10.10.0.100 (10.10.0.100) 56(84) bytes of data.
64 bytes from 10.10.0.100: icmp_seq=1 ttl=63 time=0.499 ms

--- 10.10.0.100 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.499/0.499/0.499/0.000 ms

Test DUT0 Source IP

Description

Captures BFD packets and verifies the source address is correct when packets are sent from DUT0.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address 10.10.0.100/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.200 bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.10.0.200/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.100 bfd source-ip 10.10.0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Test DUT1 Source IP

Description

Captures BFD packets and verifies the source address is correct when packets are sent from DUT1.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address 10.10.0.100/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.200 bfd source-ip 10.10.0.200
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.10.0.200/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.100 bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Test Profile

Description

Checks BFD profile in static routes.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address 10.10.0.100/24
set protocols bfd profile PFL detect-multiplier 5
set protocols bfd profile PFL echo-interval 60
set protocols bfd profile PFL echo-mode
set protocols bfd profile PFL passive-mode
set protocols bfd profile PFL receive-interval 400
set protocols bfd profile PFL transmit-interval 400
set protocols static route 0.0.0.0/0 next-hop 10.10.0.200 bfd profile PFL
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.10.0.200/24
set protocols static route 0.0.0.0/0 next-hop 10.10.0.100 bfd
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

10.10.0.200
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 3656959036
                Remote ID: 0
                Passive mode
                Status: down
                Downtime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 5
                        Receive interval: 400ms
                        Transmission interval: 400ms
                        Echo receive interval: 60ms
                        Echo transmission interval: 60ms
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 4: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Detect-multiplier: 5
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 3656959036
                Remote ID: 0
                Passive mode
                Status: down
                Downtime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 5
                        Receive interval: 400ms
                        Transmission interval: 400ms
                        Echo receive interval: 60ms
                        Echo transmission interval: 60ms
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 5: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Echo receive interval: 60ms
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 3656959036
                Remote ID: 0
                Passive mode
                Status: down
                Downtime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 5
                        Receive interval: 400ms
                        Transmission interval: 400ms
                        Echo receive interval: 60ms
                        Echo transmission interval: 60ms
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 6: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Echo transmission interval: 60ms
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 3656959036
                Remote ID: 0
                Passive mode
                Status: down
                Downtime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 5
                        Receive interval: 400ms
                        Transmission interval: 400ms
                        Echo receive interval: 60ms
                        Echo transmission interval: 60ms
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 7: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Passive mode
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 3656959036
                Remote ID: 0
                Passive mode
                Status: down
                Downtime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 5
                        Receive interval: 400ms
                        Transmission interval: 400ms
                        Echo receive interval: 60ms
                        Echo transmission interval: 60ms
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 8: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Receive interval: 400ms
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 3656959036
                Remote ID: 0
                Passive mode
                Status: down
                Downtime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 5
                        Receive interval: 400ms
                        Transmission interval: 400ms
                        Echo receive interval: 60ms
                        Echo transmission interval: 60ms
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled

Step 9: Run command protocols bfd show peers at DUT0 and check if output matches the following regular expressions:

Transmission interval: 400ms
Show output
BFD Peers:
        peer 10.10.0.200 vrf default
                ID: 3656959036
                Remote ID: 0
                Passive mode
                Status: down
                Downtime: 2 second(s)
                Diagnostics: ok
                Remote diagnostics: ok
                Peer Type: dynamic
                RTT min/avg/max: 0/0/0 usec
                Local timers:
                        Detect-multiplier: 5
                        Receive interval: 400ms
                        Transmission interval: 400ms
                        Echo receive interval: 60ms
                        Echo transmission interval: 60ms
                Remote timers:
                        Detect-multiplier: 3
                        Receive interval: 1000ms
                        Transmission interval: 1000ms
                        Echo receive interval: disabled