Relay

This scenario shows how to configure service dhcp-relay. The relay agent must be used when the DHCP server and the DHCP clients are not connected to the same layer 2 domain.

../../../_images/toplogy.svg

Test DHCP Relay

Description

This example demonstrates how to configure a DHCP relay instance in DUT0 to forward DHCP requests from DUT2 to DUT1.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.231 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.231/0.231/0.231/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Giaddr

Description

This example demonstrates how to set the gateway IP address (giaddr) in the IP address. This value must be set in an IP address that the DHCP server can reach.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.3/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1 giaddr 20.0.0.3
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.241 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.241/0.241/0.241/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.3
Show output
Apr 10 18:56:29.268447 osdx systemd-journald[1764]: Runtime Journal (/run/log/journal/05ba5a9ee053420dac2414195c972f49) is 1.0M, max 7.2M, 6.2M free.
Apr 10 18:56:29.271373 osdx systemd-journald[1764]: Received client request to rotate journal, rotating.
Apr 10 18:56:29.271451 osdx systemd-journald[1764]: Vacuuming done, freed 0B of archived journals from /run/log/journal/05ba5a9ee053420dac2414195c972f49.
Apr 10 18:56:29.278778 osdx OSDxCLI[223617]: User 'admin' executed a new command: 'system journal clear'.
Apr 10 18:56:29.754790 osdx osdx-coredump[248959]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Apr 10 18:56:29.762803 osdx OSDxCLI[223617]: User 'admin' executed a new command: 'system coredump delete all'.
Apr 10 18:56:31.416735 osdx OSDxCLI[223617]: User 'admin' entered the configuration menu.
Apr 10 18:56:31.498901 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Apr 10 18:56:31.596415 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Apr 10 18:56:31.745808 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Apr 10 18:56:31.821869 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Apr 10 18:56:31.935105 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'show working'.
Apr 10 18:56:32.010089 osdx ubnt-cfgd[248979]: inactive
Apr 10 18:56:32.083894 osdx INFO[248989]: FRR daemons did not change
Apr 10 18:56:32.103346 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Apr 10 18:56:32.130183 osdx (udev-worker)[249039]: Network interface NamePolicy= disabled on kernel command line.
Apr 10 18:56:32.251749 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Apr 10 18:56:32.253650 osdx cfgd[1456]: [223617]Completed change to active configuration
Apr 10 18:56:32.256208 osdx dhcpd[249106]: Wrote 0 leases to leases file.
Apr 10 18:56:32.271843 osdx OSDxCLI[223617]: User 'admin' committed the configuration.
Apr 10 18:56:32.296638 osdx dhcpd[249106]:
Apr 10 18:56:32.297787 osdx dhcpd[249106]: No subnet declaration for eth0 (no IPv4 addresses).
Apr 10 18:56:32.297949 osdx dhcpd[249106]: ** Ignoring requests on eth0.  If this is not what
Apr 10 18:56:32.297952 osdx dhcpd[249106]:    you want, please write a subnet declaration
Apr 10 18:56:32.297954 osdx dhcpd[249106]:    in your dhcpd.conf file for the network segment
Apr 10 18:56:32.297957 osdx dhcpd[249106]:    to which interface eth0 is attached. **
Apr 10 18:56:32.297960 osdx dhcpd[249106]:
Apr 10 18:56:32.317681 osdx OSDxCLI[223617]: User 'admin' left the configuration menu.
Apr 10 18:56:32.319544 osdx dhcpd[249106]: Server starting service.
Apr 10 18:56:33.160328 osdx dhcpd[249106]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.3
Apr 10 18:56:34.160959 osdx dhcpd[249106]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
Apr 10 18:56:34.161628 osdx dhcpd[249106]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.3
Apr 10 18:56:34.174088 osdx dhcpd[249106]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.3

Test DHCP Relay With GRE Tunnel

Description

This example demonstrates how to configure a DHCP relay that forwards DHCP requests to the DHCP server through a GRE tunnel (upstream).

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces tunnel tun1 address 1.0.0.2/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.2
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp holdtime 5
set interfaces tunnel tun1 nhrp nhs 1.0.0.1 nbma 10.0.0.1
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 1.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS upstream-interface tun1
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces tunnel tun1 address 1.0.0.1/32
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-address 10.0.0.1
set interfaces tunnel tun1 local-interface eth0.100
set interfaces tunnel tun1 nhrp
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set protocols static route 20.0.0.0/24 next-hop 1.0.0.2
set service dhcp-server shared-network dummy subnet 1.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.156 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.156/0.156/0.156/0.000 ms

Step 5: Ping IP address 1.0.0.1 from DUT0:

admin@DUT0$ ping 1.0.0.1 count 1 size 56 timeout 1
Show output
PING 1.0.0.1 (1.0.0.1) 56(84) bytes of data.
64 bytes from 1.0.0.1: icmp_seq=1 ttl=64 time=0.302 ms

--- 1.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.302/0.302/0.302/0.000 ms

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Test DHCP Relay With Multiple Instances

Description

This example demonstrates how to configure multiple DHCP relay instances.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set interfaces ethernet eth1 vif 300 address 30.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set service dhcp-relay INS2 downstream-interface eth1.300
set service dhcp-relay INS2 server 10.0.0.1
set service dhcp-relay INS2 upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set interfaces ethernet eth0 vif 300 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.221 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.221/0.221/0.221/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

30.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
eth0.300  30.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 7: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

DHCPACK on 20.0.0.50 to [^\)]+\) via 20.0.0.2
DHCPACK on 30.0.0.50 to [^\)]+\) via 30.0.0.2
Show output
Apr 10 18:56:55.285930 osdx systemd-journald[1764]: Runtime Journal (/run/log/journal/05ba5a9ee053420dac2414195c972f49) is 1.0M, max 7.2M, 6.2M free.
Apr 10 18:56:55.288110 osdx systemd-journald[1764]: Received client request to rotate journal, rotating.
Apr 10 18:56:55.288160 osdx systemd-journald[1764]: Vacuuming done, freed 0B of archived journals from /run/log/journal/05ba5a9ee053420dac2414195c972f49.
Apr 10 18:56:55.296551 osdx OSDxCLI[223617]: User 'admin' executed a new command: 'system journal clear'.
Apr 10 18:56:55.772753 osdx osdx-coredump[249916]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Apr 10 18:56:55.783439 osdx OSDxCLI[223617]: User 'admin' executed a new command: 'system coredump delete all'.
Apr 10 18:56:57.610397 osdx OSDxCLI[223617]: User 'admin' entered the configuration menu.
Apr 10 18:56:57.679379 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Apr 10 18:56:57.767030 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Apr 10 18:56:57.831563 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Apr 10 18:56:57.926331 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Apr 10 18:56:57.986788 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote2 subnet 30.0.0.0/24 start 30.0.0.50 stop 30.0.0.50'.
Apr 10 18:56:58.099786 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'show working'.
Apr 10 18:56:58.166029 osdx ubnt-cfgd[249937]: inactive
Apr 10 18:56:58.244902 osdx INFO[249949]: FRR daemons did not change
Apr 10 18:56:58.267544 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Apr 10 18:56:58.302282 osdx (udev-worker)[250001]: Network interface NamePolicy= disabled on kernel command line.
Apr 10 18:56:58.428118 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Apr 10 18:56:58.431910 osdx cfgd[1456]: [223617]Completed change to active configuration
Apr 10 18:56:58.445489 osdx OSDxCLI[223617]: User 'admin' committed the configuration.
Apr 10 18:56:58.448993 osdx dhcpd[250066]: Wrote 0 leases to leases file.
Apr 10 18:56:58.476393 osdx OSDxCLI[223617]: User 'admin' left the configuration menu.
Apr 10 18:56:58.483383 osdx dhcpd[250066]:
Apr 10 18:56:58.483391 osdx dhcpd[250066]: No subnet declaration for eth0 (no IPv4 addresses).
Apr 10 18:56:58.483395 osdx dhcpd[250066]: ** Ignoring requests on eth0.  If this is not what
Apr 10 18:56:58.483398 osdx dhcpd[250066]:    you want, please write a subnet declaration
Apr 10 18:56:58.483400 osdx dhcpd[250066]:    in your dhcpd.conf file for the network segment
Apr 10 18:56:58.483403 osdx dhcpd[250066]:    to which interface eth0 is attached. **
Apr 10 18:56:58.483406 osdx dhcpd[250066]:
Apr 10 18:56:58.499757 osdx dhcpd[250066]: Server starting service.
Apr 10 18:56:59.216510 osdx dhcpd[250066]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Apr 10 18:56:59.360278 osdx dhcpd[250066]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 30.0.0.2
Apr 10 18:57:00.217165 osdx dhcpd[250066]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Apr 10 18:57:00.217794 osdx dhcpd[250066]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Apr 10 18:57:00.259904 osdx dhcpd[250066]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Apr 10 18:57:00.360478 osdx dhcpd[250066]: DHCPOFFER on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
Apr 10 18:57:00.361155 osdx dhcpd[250066]: DHCPREQUEST for 30.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 30.0.0.2
Apr 10 18:57:00.388215 osdx dhcpd[250066]: DHCPACK on 30.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 30.0.0.2