Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.228 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.228/0.228/0.228/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
May 14 10:23:43.275210 osdx systemd-journald[1753]: Runtime Journal (/run/log/journal/899392cd00944cdaa29aa3964bffbd0e) is 1.0M, max 7.2M, 6.2M free.
May 14 10:23:43.277541 osdx systemd-journald[1753]: Received client request to rotate journal, rotating.
May 14 10:23:43.277603 osdx systemd-journald[1753]: Vacuuming done, freed 0B of archived journals from /run/log/journal/899392cd00944cdaa29aa3964bffbd0e.
May 14 10:23:43.285248 osdx OSDxCLI[154664]: User 'admin' executed a new command: 'system journal clear'.
May 14 10:23:43.716591 osdx osdx-coredump[249524]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
May 14 10:23:43.724329 osdx OSDxCLI[154664]: User 'admin' executed a new command: 'system coredump delete all'.
May 14 10:23:45.250403 osdx OSDxCLI[154664]: User 'admin' entered the configuration menu.
May 14 10:23:45.326233 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
May 14 10:23:45.407554 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
May 14 10:23:45.468936 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
May 14 10:23:45.568672 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
May 14 10:23:45.627694 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
May 14 10:23:45.721117 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
May 14 10:23:45.780373 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
May 14 10:23:45.877957 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
May 14 10:23:45.958816 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
May 14 10:23:46.034182 osdx OSDxCLI[154664]: User 'admin' added a new cfg line: 'show working'.
May 14 10:23:46.130778 osdx ubnt-cfgd[249549]: inactive
May 14 10:23:46.192140 osdx INFO[249574]: FRR daemons did not change
May 14 10:23:46.213562 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
May 14 10:23:46.238329 osdx (udev-worker)[249624]: Network interface NamePolicy= disabled on kernel command line.
May 14 10:23:46.665998 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
May 14 10:23:46.668631 osdx cfgd[1455]: [154664]Completed change to active configuration
May 14 10:23:46.669866 osdx dhcpd[249717]: Wrote 0 leases to leases file.
May 14 10:23:46.681292 osdx OSDxCLI[154664]: User 'admin' committed the configuration.
May 14 10:23:46.699888 osdx OSDxCLI[154664]: User 'admin' left the configuration menu.
May 14 10:23:46.700595 osdx dhcpd[249717]:
May 14 10:23:46.700607 osdx dhcpd[249717]: No subnet declaration for eth0 (no IPv4 addresses).
May 14 10:23:46.700611 osdx dhcpd[249717]: ** Ignoring requests on eth0.  If this is not what
May 14 10:23:46.700614 osdx dhcpd[249717]:    you want, please write a subnet declaration
May 14 10:23:46.700617 osdx dhcpd[249717]:    in your dhcpd.conf file for the network segment
May 14 10:23:46.700620 osdx dhcpd[249717]:    to which interface eth0 is attached. **
May 14 10:23:46.700623 osdx dhcpd[249717]:
May 14 10:23:46.717747 osdx dhcpd[249717]: Server starting service.
May 14 10:23:47.401454 osdx dhcpd[249717]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
May 14 10:23:47.401623 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=12237 DF PROTO=UDP SPT=67 DPT=67 LEN=308
May 14 10:23:48.401968 osdx dhcpd[249717]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
May 14 10:23:48.402585 osdx dhcpd[249717]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
May 14 10:23:48.405527 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=12367 DF PROTO=UDP SPT=67 DPT=67 LEN=308
May 14 10:23:48.431452 osdx dhcpd[249717]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2