Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.209 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.209/0.209/0.209/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
May 13 17:07:49.285826 osdx systemd-journald[1556]: Runtime Journal (/run/log/journal/40d471a1719548efa28850ccdbbdff9f) is 1.0M, max 7.2M, 6.2M free.
May 13 17:07:49.289244 osdx systemd-journald[1556]: Received client request to rotate journal, rotating.
May 13 17:07:49.289294 osdx systemd-journald[1556]: Vacuuming done, freed 0B of archived journals from /run/log/journal/40d471a1719548efa28850ccdbbdff9f.
May 13 17:07:49.294697 osdx OSDxCLI[163437]: User 'admin' executed a new command: 'system journal clear'.
May 13 17:07:49.704110 osdx osdx-coredump[256913]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
May 13 17:07:49.712249 osdx OSDxCLI[163437]: User 'admin' executed a new command: 'system coredump delete all'.
May 13 17:07:51.222819 osdx OSDxCLI[163437]: User 'admin' entered the configuration menu.
May 13 17:07:51.299851 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
May 13 17:07:51.387235 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
May 13 17:07:51.447451 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
May 13 17:07:51.529652 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
May 13 17:07:51.590817 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
May 13 17:07:51.687259 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
May 13 17:07:51.745951 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
May 13 17:07:51.848609 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
May 13 17:07:51.905453 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
May 13 17:07:52.019248 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'show working'.
May 13 17:07:52.088922 osdx ubnt-cfgd[256938]: inactive
May 13 17:07:52.163354 osdx INFO[256963]: FRR daemons did not change
May 13 17:07:52.185270 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
May 13 17:07:52.203929 osdx (udev-worker)[257012]: Network interface NamePolicy= disabled on kernel command line.
May 13 17:07:52.786404 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
May 13 17:07:52.792141 osdx cfgd[1253]: [163437]Completed change to active configuration
May 13 17:07:52.792855 osdx dhcpd[257106]: Wrote 0 leases to leases file.
May 13 17:07:52.814549 osdx OSDxCLI[163437]: User 'admin' committed the configuration.
May 13 17:07:52.821178 osdx dhcpd[257106]:
May 13 17:07:52.821183 osdx dhcpd[257106]: No subnet declaration for eth0 (no IPv4 addresses).
May 13 17:07:52.821185 osdx dhcpd[257106]: ** Ignoring requests on eth0.  If this is not what
May 13 17:07:52.821188 osdx dhcpd[257106]:    you want, please write a subnet declaration
May 13 17:07:52.821190 osdx dhcpd[257106]:    in your dhcpd.conf file for the network segment
May 13 17:07:52.821193 osdx dhcpd[257106]:    to which interface eth0 is attached. **
May 13 17:07:52.821195 osdx dhcpd[257106]:
May 13 17:07:52.829370 osdx dhcpd[257106]: Server starting service.
May 13 17:07:52.832300 osdx OSDxCLI[163437]: User 'admin' left the configuration menu.
May 13 17:07:53.466278 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=53245 DF PROTO=UDP SPT=67 DPT=67 LEN=308
May 13 17:07:53.466317 osdx dhcpd[257106]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
May 13 17:07:54.466573 osdx dhcpd[257106]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
May 13 17:07:54.467165 osdx dhcpd[257106]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
May 13 17:07:54.469254 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=53488 DF PROTO=UDP SPT=67 DPT=67 LEN=308
May 13 17:07:54.489290 osdx dhcpd[257106]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2