Cipher Server

Test suite to validate using one or multiple ciphers to protect DoH connection

TLS v1.3 Connection

Description

Sets up the DUT0 as a server, DUT1 as a client and ensures the communication between them is secured by TLS v1.3.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces ethernet eth0 address 10.215.168.64/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy server cert file 'running://dns.dut0.crt'
set service dns proxy server cert key 'running://dns.dut0.key'
set service dns proxy server-name RD
set service dns proxy static RD protocol dns-over-https hash 2bf8e614357d7ffe91a319d2d25e8046a64f2d349a757e66b5e8c8ccea2231f5
set service dns proxy static RD protocol dns-over-https host name remote.dns
set service dns proxy static RD protocol dns-over-https ip 10.215.168.1
set service dns static host-name teldat.com inet 10.11.12.13
set system certificate trust 'running://remote.dns-server.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 address 10.215.168.65/24
set protocols static route 0.0.0.0/0 next-hop 10.215.168.1
set service dns proxy log level 0
set service dns proxy server-name DUT0
set service dns proxy static DUT0 protocol dns-over-https hash b2145fae98815abb82e81cfa2c37760ad353e55fd5f6f599eb3b68dbff0fe3e2
set service dns proxy static DUT0 protocol dns-over-https host name dns.dut0
set service dns proxy static DUT0 protocol dns-over-https host port 3000
set service dns proxy static DUT0 protocol dns-over-https ip 10.215.168.64
set service dns resolver local
set service dns static host-name dns.dut0 inet 10.215.168.64
set service ssh
set system certificate trust 'running://CA.crt'
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 3: Run command system journal show | cat at DUT1 and expect this output:

Show output
May 13 16:26:49.291265 osdx systemd-journald[1556]: Runtime Journal (/run/log/journal/40d471a1719548efa28850ccdbbdff9f) is 992.0K, max 7.2M, 6.2M free.
May 13 16:26:49.293994 osdx systemd-journald[1556]: Received client request to rotate journal, rotating.
May 13 16:26:49.294047 osdx systemd-journald[1556]: Vacuuming done, freed 0B of archived journals from /run/log/journal/40d471a1719548efa28850ccdbbdff9f.
May 13 16:26:49.303602 osdx OSDxCLI[163437]: User 'admin' executed a new command: 'system journal clear'.
May 13 16:26:49.729216 osdx osdx-coredump[222939]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
May 13 16:26:49.737684 osdx OSDxCLI[163437]: User 'admin' executed a new command: 'system coredump delete all'.
May 13 16:26:50.863433 osdx OSDxCLI[163437]: User 'admin' entered the configuration menu.
May 13 16:26:50.945927 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set interfaces ethernet eth0 address 10.215.168.65/24'.
May 13 16:26:51.028187 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.215.168.1'.
May 13 16:26:51.081091 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service ssh'.
May 13 16:26:51.222442 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'show working'.
May 13 16:26:51.294586 osdx ubnt-cfgd[222958]: inactive
May 13 16:26:51.320112 osdx INFO[222972]: FRR daemons did not change
May 13 16:26:51.342007 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
May 13 16:26:51.502275 osdx systemd[1]: Starting ssh.service - OpenBSD Secure Shell server...
May 13 16:26:51.517893 osdx sshd[223086]: Server listening on 0.0.0.0 port 22.
May 13 16:26:51.518128 osdx sshd[223086]: Server listening on :: port 22.
May 13 16:26:51.518248 osdx systemd[1]: Started ssh.service - OpenBSD Secure Shell server.
May 13 16:26:51.539934 osdx cfgd[1253]: [163437]Completed change to active configuration
May 13 16:26:51.557286 osdx OSDxCLI[163437]: User 'admin' committed the configuration.
May 13 16:26:51.581480 osdx OSDxCLI[163437]: User 'admin' left the configuration menu.
May 13 16:26:51.729250 osdx OSDxCLI[163437]: User 'admin' executed a new command: 'ping 10.215.168.64 count 1 size 56 timeout 1'.
May 13 16:26:53.455631 osdx OSDxCLI[163437]: User 'admin' entered the configuration menu.
May 13 16:26:53.561343 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dns static host-name dns.dut0 inet 10.215.168.64'.
May 13 16:26:53.617585 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set system certificate trust running://CA.crt'.
May 13 16:26:53.725141 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dns proxy server-name DUT0'.
May 13 16:26:53.816109 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https host name dns.dut0'.
May 13 16:26:53.916374 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https host port 3000'.
May 13 16:26:54.031039 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https ip 10.215.168.64'.
May 13 16:26:54.110552 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dns proxy static DUT0 protocol dns-over-https hash b2145fae98815abb82e81cfa2c37760ad353e55fd5f6f599eb3b68dbff0fe3e2'.
May 13 16:26:54.217325 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dns proxy log level 0'.
May 13 16:26:54.327117 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'set service dns resolver local'.
May 13 16:26:54.444905 osdx OSDxCLI[163437]: User 'admin' added a new cfg line: 'show working'.
May 13 16:26:54.522171 osdx ubnt-cfgd[223143]: inactive
May 13 16:26:54.545128 osdx INFO[223151]: FRR daemons did not change
May 13 16:26:54.560859 osdx ca-certificates[223167]: Updating certificates in /etc/ssl/certs...
May 13 16:26:55.058777 osdx ca-certificates[224172]: 1 added, 0 removed; done.
May 13 16:26:55.061912 osdx ca-certificates[224177]: Running hooks in /etc/ca-certificates/update.d...
May 13 16:26:55.064860 osdx ca-certificates[224179]: done.
May 13 16:26:55.182363 osdx systemd[1]: Started dnscrypt-proxy.service - DNSCrypt client proxy.
May 13 16:26:55.183922 osdx cfgd[1253]: [163437]Completed change to active configuration
May 13 16:26:55.187606 osdx OSDxCLI[163437]: User 'admin' committed the configuration.
May 13 16:26:55.205803 osdx dnscrypt-proxy[224239]: dnscrypt-proxy 2.0.45
May 13 16:26:55.205859 osdx dnscrypt-proxy[224239]: Network connectivity detected
May 13 16:26:55.206066 osdx dnscrypt-proxy[224239]: Dropping privileges
May 13 16:26:55.208325 osdx dnscrypt-proxy[224239]: Network connectivity detected
May 13 16:26:55.208362 osdx dnscrypt-proxy[224239]: Now listening to 127.0.0.1:53 [UDP]
May 13 16:26:55.208367 osdx dnscrypt-proxy[224239]: Now listening to 127.0.0.1:53 [TCP]
May 13 16:26:55.208399 osdx dnscrypt-proxy[224239]: Firefox workaround initialized
May 13 16:26:55.208404 osdx dnscrypt-proxy[224239]: Loading the set of cloaking rules from [/tmp/tmpwo1pp_4y]
May 13 16:26:55.219864 osdx OSDxCLI[163437]: User 'admin' left the configuration menu.
May 13 16:26:55.379699 osdx OSDxCLI[163437]: User 'admin' executed a new command: 'system journal show | cat'.
May 13 16:26:55.381915 osdx dnscrypt-proxy[224239]: [DUT0] TLS version: 304 - Protocol: h2 - Cipher suite: 4867
May 13 16:26:55.381933 osdx dnscrypt-proxy[224239]: [DUT0] OK (DoH) - rtt: 108ms
May 13 16:26:55.381947 osdx dnscrypt-proxy[224239]: Server with the lowest initial latency: DUT0 (rtt: 108ms)
May 13 16:26:55.381956 osdx dnscrypt-proxy[224239]: dnscrypt-proxy is ready - live servers: 1