Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.419 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.419/0.419/0.419/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c30/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c30/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Jul 30 12:00:47.241765 osdx systemd-journald[1361]: Runtime Journal (/run/log/journal/022a18c941d64f479a590b363c3a1b1d) is 1.2M, max 9.7M, 8.4M free.
Jul 30 12:00:47.244228 osdx systemd-journald[1361]: Received client request to rotate journal, rotating.
Jul 30 12:00:47.244272 osdx systemd-journald[1361]: Vacuuming done, freed 0B of archived journals from /run/log/journal/022a18c941d64f479a590b363c3a1b1d.
Jul 30 12:00:47.251426 osdx OSDxCLI[96653]: User 'admin' executed a new command: 'system journal clear'.
Jul 30 12:00:47.614633 osdx osdx-coredump[129141]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Jul 30 12:00:47.621977 osdx OSDxCLI[96653]: User 'admin' executed a new command: 'system coredump delete all'.
Jul 30 12:00:48.920710 osdx OSDxCLI[96653]: User 'admin' entered the configuration menu.
Jul 30 12:00:48.984115 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Jul 30 12:00:49.070382 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Jul 30 12:00:49.122825 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Jul 30 12:00:49.205006 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Jul 30 12:00:49.251766 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Jul 30 12:00:49.343880 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Jul 30 12:00:49.393032 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Jul 30 12:00:49.510753 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Jul 30 12:00:49.564048 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Jul 30 12:00:49.670210 osdx OSDxCLI[96653]: User 'admin' added a new cfg line: 'show working'.
Jul 30 12:00:49.788551 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Jul 30 12:00:49.813077 osdx (udev-worker)[129230]: Network interface NamePolicy= disabled on kernel command line.
Jul 30 12:00:49.988529 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Jul 30 12:00:49.990525 osdx cfgd[1029]: [96653]Completed change to active configuration
Jul 30 12:00:49.994207 osdx dhcpd[129269]: Wrote 0 leases to leases file.
Jul 30 12:00:50.017166 osdx OSDxCLI[96653]: User 'admin' committed the configuration.
Jul 30 12:00:50.019661 osdx dhcpd[129269]:
Jul 30 12:00:50.019665 osdx dhcpd[129269]: No subnet declaration for eth0 (no IPv4 addresses).
Jul 30 12:00:50.019667 osdx dhcpd[129269]: ** Ignoring requests on eth0.  If this is not what
Jul 30 12:00:50.019669 osdx dhcpd[129269]:    you want, please write a subnet declaration
Jul 30 12:00:50.019671 osdx dhcpd[129269]:    in your dhcpd.conf file for the network segment
Jul 30 12:00:50.019673 osdx dhcpd[129269]:    to which interface eth0 is attached. **
Jul 30 12:00:50.019675 osdx dhcpd[129269]:
Jul 30 12:00:50.024326 osdx dhcpd[129269]: Server starting service.
Jul 30 12:00:50.031090 osdx OSDxCLI[96653]: User 'admin' left the configuration menu.
Jul 30 12:00:50.567214 osdx dhcpd[129269]: DHCPDISCOVER from de:ad:be:ef:6c:30 via 20.0.0.2
Jul 30 12:00:50.568274 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:20:de:ad:be:ef:6c:10:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=9107 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Jul 30 12:00:51.568201 osdx dhcpd[129269]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 30 12:00:51.569307 osdx dhcpd[129269]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:30 (osdx) via 20.0.0.2
Jul 30 12:00:51.572265 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:20:de:ad:be:ef:6c:10:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=9321 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Jul 30 12:00:51.590048 osdx dhcpd[129269]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:30 (osdx) via 20.0.0.2