Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0:

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1:

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2:

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.240 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.240/0.240/0.240/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Oct 30 12:26:26.272479 osdx systemd-journald[1716]: Runtime Journal (/run/log/journal/ec1e6df9c86a4e70bec24fbb88487109) is 1.3M, max 9.7M, 8.4M free.
Oct 30 12:26:26.276334 osdx systemd-journald[1716]: Received client request to rotate journal, rotating.
Oct 30 12:26:26.276385 osdx systemd-journald[1716]: Vacuuming done, freed 0B of archived journals from /run/log/journal/ec1e6df9c86a4e70bec24fbb88487109.
Oct 30 12:26:26.281930 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system journal clear'.
Oct 30 12:26:26.696851 osdx osdx-coredump[105124]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Oct 30 12:26:26.704466 osdx OSDxCLI[1928]: User 'admin' executed a new command: 'system coredump delete all'.
Oct 30 12:26:28.250975 osdx OSDxCLI[1928]: User 'admin' entered the configuration menu.
Oct 30 12:26:28.325040 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Oct 30 12:26:28.410539 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Oct 30 12:26:28.467992 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Oct 30 12:26:28.577564 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Oct 30 12:26:28.658394 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Oct 30 12:26:28.762418 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Oct 30 12:26:28.834691 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Oct 30 12:26:28.931517 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Oct 30 12:26:28.993027 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Oct 30 12:26:29.098078 osdx ERROR[105140]: unexpected
                                           Traceback (most recent call last):
                                             File "osdx/bin/op/fan_control.py", line 23, in _send_fan_control_cmd
                                           FileNotFoundError: [Errno 2] No such file or directory
Oct 30 12:26:29.100212 osdx OSDxCLI[1928]: User 'admin' added a new cfg line: 'show working'.
Oct 30 12:26:29.268341 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Oct 30 12:26:29.290847 osdx (udev-worker)[105215]: Network interface NamePolicy= disabled on kernel command line.
Oct 30 12:26:29.596886 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Oct 30 12:26:29.599623 osdx cfgd[1427]: [1928]Completed change to active configuration
Oct 30 12:26:29.600437 osdx dhcpd[105258]: Wrote 0 leases to leases file.
Oct 30 12:26:29.632161 osdx OSDxCLI[1928]: User 'admin' committed the configuration.
Oct 30 12:26:29.642422 osdx dhcpd[105258]:
Oct 30 12:26:29.642428 osdx dhcpd[105258]: No subnet declaration for eth0 (no IPv4 addresses).
Oct 30 12:26:29.642431 osdx dhcpd[105258]: ** Ignoring requests on eth0.  If this is not what
Oct 30 12:26:29.642433 osdx dhcpd[105258]:    you want, please write a subnet declaration
Oct 30 12:26:29.642435 osdx dhcpd[105258]:    in your dhcpd.conf file for the network segment
Oct 30 12:26:29.642438 osdx dhcpd[105258]:    to which interface eth0 is attached. **
Oct 30 12:26:29.642440 osdx dhcpd[105258]:
Oct 30 12:26:29.650198 osdx OSDxCLI[1928]: User 'admin' left the configuration menu.
Oct 30 12:26:29.652443 osdx dhcpd[105258]: Server starting service.
Oct 30 12:26:30.255236 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=4344 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Oct 30 12:26:30.255307 osdx dhcpd[105258]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Oct 30 12:26:31.256133 osdx dhcpd[105258]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Oct 30 12:26:31.256731 osdx dhcpd[105258]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Oct 30 12:26:31.260336 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=4367 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Oct 30 12:26:31.289315 osdx dhcpd[105258]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2