Local-Address

This scenario shows how to configure a DHCP relay agent to forward DHCP requests. By default, the local-address option uses a custom local IP as source address for upstream traffic.

../../../../_images/local.svg

Test DHCP Relay With Local-Address

Description

This example shows how to configure the local-address option. This command can be used to set the source address for upstream traffic.

Scenario

Step 1: Set the following configuration in DUT0 :

set interfaces dummy dum0 address 1.1.1.1/32
set interfaces ethernet eth0 vif 100 address 10.0.0.2/24
set interfaces ethernet eth1 vif 200 address 20.0.0.2/24
set service dhcp-relay INS downstream-interface eth1.200
set service dhcp-relay INS local-address 1.1.1.1
set service dhcp-relay INS server 10.0.0.1
set service dhcp-relay INS upstream-interface eth0.100
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 2: Set the following configuration in DUT1 :

set interfaces ethernet eth0 vif 100 address 10.0.0.1/24
set interfaces ethernet eth0 vif 100 traffic policy in LOGGER
set protocols static route 0.0.0.0/0 next-hop 10.0.0.2
set service dhcp-server shared-network dummy subnet 10.0.0.1/32
set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'
set traffic policy LOGGER rule 1 log prefix DHCP_
set traffic policy LOGGER rule 1 selector UDP
set traffic selector UDP rule 1 destination port 67
set traffic selector UDP rule 1 protocol udp

Step 3: Set the following configuration in DUT2 :

set interfaces ethernet eth0 vif 200 address dhcp
set system login user admin authentication encrypted-password '$6$GSjsCj8gHLv$/VcqU6FLi6CT2Oxn0MJQ2C2tqnRDrYKNF8HIYWJp68nvXvPdFccDsT04.WtigUONbKYrgKg8d6rEs8PjljMkH0'

Step 4: Ping IP address 10.0.0.1 from DUT0:

admin@DUT0$ ping 10.0.0.1 count 1 size 56 timeout 1
Show output
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.236 ms

--- 10.0.0.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.236/0.236/0.236/0.000 ms

Step 5: Run command interfaces ethernet show at DUT2 and check if output contains the following tokens:

20.0.0.50
Show output
---------------------------------------------------------------------
  Name             IP Address           Admin  Oper  Vrf  Description
---------------------------------------------------------------------
    eth0  fe80::dcad:beff:feef:6c20/64  up     up
eth0.200  20.0.0.50/24                  up     up
          fe80::dcad:beff:feef:6c20/64
    eth1                                down   down

Step 6: Run command system journal show | cat at DUT1 and check if output matches the following regular expressions:

SRC=1.1.1.1 DST=10.0.0.1
Show output
Apr 10 18:55:52.316848 osdx systemd-journald[1764]: Runtime Journal (/run/log/journal/05ba5a9ee053420dac2414195c972f49) is 1008.0K, max 7.2M, 6.2M free.
Apr 10 18:55:52.317818 osdx systemd-journald[1764]: Received client request to rotate journal, rotating.
Apr 10 18:55:52.317866 osdx systemd-journald[1764]: Vacuuming done, freed 0B of archived journals from /run/log/journal/05ba5a9ee053420dac2414195c972f49.
Apr 10 18:55:52.326618 osdx OSDxCLI[223617]: User 'admin' executed a new command: 'system journal clear'.
Apr 10 18:55:52.780722 osdx osdx-coredump[247866]: Deleting all coredumps in /opt/vyatta/etc/config/coredump...
Apr 10 18:55:52.789798 osdx OSDxCLI[223617]: User 'admin' executed a new command: 'system coredump delete all'.
Apr 10 18:55:54.465321 osdx OSDxCLI[223617]: User 'admin' entered the configuration menu.
Apr 10 18:55:54.582935 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set interfaces eth0.100 address 10.0.0.1/24'.
Apr 10 18:55:54.685761 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network dummy subnet 10.0.0.1/32'.
Apr 10 18:55:54.747353 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set service dhcp-server shared-network remote subnet 20.0.0.0/24 start 20.0.0.50 stop 20.0.0.50'.
Apr 10 18:55:54.848066 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set protocols static route 0.0.0.0/0 next-hop 10.0.0.2'.
Apr 10 18:55:54.918252 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 log prefix DHCP_'.
Apr 10 18:55:55.042882 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set traffic policy LOGGER rule 1 selector UDP'.
Apr 10 18:55:55.102987 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 protocol udp'.
Apr 10 18:55:55.221242 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set traffic selector UDP rule 1 destination port 67'.
Apr 10 18:55:55.294393 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'set interfaces eth0.100 traffic policy in LOGGER'.
Apr 10 18:55:55.410263 osdx OSDxCLI[223617]: User 'admin' added a new cfg line: 'show working'.
Apr 10 18:55:55.497142 osdx ubnt-cfgd[247891]: inactive
Apr 10 18:55:55.796748 osdx INFO[247916]: FRR daemons did not change
Apr 10 18:55:55.817715 osdx kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Apr 10 18:55:55.847703 osdx (udev-worker)[247966]: Network interface NamePolicy= disabled on kernel command line.
Apr 10 18:55:56.158099 osdx systemd[1]: Started dhcpd@main.service - "DHCP Server Service instance main".
Apr 10 18:55:56.162034 osdx cfgd[1456]: [223617]Completed change to active configuration
Apr 10 18:55:56.173410 osdx OSDxCLI[223617]: User 'admin' committed the configuration.
Apr 10 18:55:56.204265 osdx OSDxCLI[223617]: User 'admin' left the configuration menu.
Apr 10 18:55:56.217307 osdx dhcpd[248053]: Wrote 0 leases to leases file.
Apr 10 18:55:56.242827 osdx dhcpd[248053]:
Apr 10 18:55:56.242931 osdx dhcpd[248053]: No subnet declaration for eth0 (no IPv4 addresses).
Apr 10 18:55:56.242974 osdx dhcpd[248053]: ** Ignoring requests on eth0.  If this is not what
Apr 10 18:55:56.243007 osdx dhcpd[248053]:    you want, please write a subnet declaration
Apr 10 18:55:56.243045 osdx dhcpd[248053]:    in your dhcpd.conf file for the network segment
Apr 10 18:55:56.243078 osdx dhcpd[248053]:    to which interface eth0 is attached. **
Apr 10 18:55:56.243111 osdx dhcpd[248053]:
Apr 10 18:55:56.257845 osdx dhcpd[248053]: Server starting service.
Apr 10 18:55:56.911023 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=1940 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Apr 10 18:55:56.911146 osdx dhcpd[248053]: DHCPDISCOVER from de:ad:be:ef:6c:20 via 20.0.0.2
Apr 10 18:55:57.911343 osdx dhcpd[248053]: DHCPOFFER on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Apr 10 18:55:57.912304 osdx kernel: [DHCP_-1] ACCEPT IN=eth0.100 OUT= MAC=de:ad:be:ef:6c:10:de:ad:be:ef:6c:00:08:00:45:00:01:48 SRC=1.1.1.1 DST=10.0.0.1 LEN=328 TOS=0x00 PREC=0x00 TTL=64 ID=2046 DF PROTO=UDP SPT=67 DPT=67 LEN=308
Apr 10 18:55:57.912277 osdx dhcpd[248053]: DHCPREQUEST for 20.0.0.50 (10.0.0.1) from de:ad:be:ef:6c:20 (osdx) via 20.0.0.2
Apr 10 18:55:57.929844 osdx dhcpd[248053]: DHCPACK on 20.0.0.50 to de:ad:be:ef:6c:20 (osdx) via 20.0.0.2